Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, so there's a single wireless network that my laptop has troubles with. My Macbook Pro used to be fine with it until it changed to using channel 13 (or 11?). Since then, after being connected to it for a while it disappears from my laptop's view. Other networks are showing up fine and other computers (including several Macs) have no troubles connecting to this network. If I clear my system cache using Onyx and then restart (sometimes a couple times) my laptop can see and connect to it again. But it seems that if I disconnect and try reconnecting I have to clear my cache again.

One thing to note is that if I put my computer to sleep while connected to this network it has no problems reconnecting on wake up.

I've got a 15" Macbook Pro 2,2 with Leopard 10.5.8.

share|improve this question
up vote 2 down vote accepted

Long story short, it turns out it was because I had Safe Eyes installed. Uninstalling it seems to have fixed the problem.

I found this out because I temporarily moved to a different laptop (Macbook) while my Macbook Pro, that was exhibiting the problems, got repaired for a separate reason. This Macbook had been connecting just fine to the problem router but since I setup my account and installed Safe Eyes it could no longer see the network. After uninstalling it, there seems to be no problems.

Safe Eyes is a parental control program and digs its roots deep into your system (the only program I use that does so) which might explain why it was causing problems. Now, why it was just this specific network and not others, I have no idea. But, problem solved. I may contact Safe Eyes support to report this problem and see if there are any known solutions, but that can wait until I have more time.

share|improve this answer
Well done - bit of a struggle, but I'm glad its fixed. Never come across this before! – alimack Mar 19 '10 at 8:54

If it happened just after a channel change (it is your network isn't it? - you change the channel at the router rather than at the Mac) it might just be interference which would give the intermittent problems you seem to be seeing. The distinguishable channels are something like 1, 6 and 13. If you have control of the router you could change the channel.

Sometimes it's not even other networks, you could be seeing interference from Microwaves and the like.

share|improve this answer
OK, its definitely your machine - I suspect corrupt preference files. Download Cocktail and check for corrupt preference files, delete as appropriate. Don't think Onyx does this. If that doesn't work, your airport card could be faulty - run the extended hardware test (hold down 'd' and reboot with system disks in drive). Is it just the one network you have problems with? Can you find another network, set it to channel 13 and see if you have the same problems? That would eliminate the possibility that it's just the one router. Details of the network might help, too - encyyption etc. – alimack Feb 18 '10 at 9:52
I suspect this is an intermittent hardware fault - can you reseat the airport card or take it to an Apple Store and get them to either reseat or replace card. AEHT sometimes struggles to pick up intermittent faults. – alimack Mar 1 '10 at 11:15
No, by 're-seat' I mean plug in and out again, in case there's some grot stuck in the pins or socket. You would need to take the case apart, so it depends on how handy you are. iFixit.comn is good for this. If it's under warranty, I'd get Apple to switch the Airport card. By AEHT, I just meant Apple Extended Hardware TEST - running the test with the box ticked for a full set of tests - it can sometimes miss intermittent faults. – alimack Mar 2 '10 at 8:53
Curiouser and curiouser - so its just a problem on a specific router at a specific frequency? Does anyone else in the office have a Macbook? It starts to look like the router again! Since there's a limit to what you can do with the router try these: Is the rest of your machine in tip top shape - you've run Disk Utility etc to verify/ repair disk and repaired permissions? They can sometimes cause strange effects. I take it you can't get near an ethernet cable/ port? – alimack Mar 2 '10 at 9:06
Well OK, this is the Apple site airport troubleshooting. I quote from a linked page: "Is just one client affected? If so, concentrate on troubleshooting client settings on that computer. Make sure that its AirPort card is properly installed, with the antenna connected." So I think you need to get your airport card looked at. – alimack Mar 3 '10 at 8:42

Ok you said you solved the issue.

BUT FYI. A USA bought Mac does not allow Wireless access on Channel 13. A way round it is to use a repeater to make the wifi connection and then plug in the Mac to the repeater via cable (effectively a LAN connection)

share|improve this answer
Well, I was able to connect to a different router set to channel 13 without a problem. And my wife's Macbook was able to connect to the problem router as well. So, at least these two Macbooks from 2007 were able to connect to two different routers set to channel 13. Maybe that's only the newer models? – donut Jul 14 '10 at 3:02

I have a MacBook 13" unibody that is unable to connect to Channel 13 on my DLink DIR-655 wireless router. Only just figured it out as I was previously unable to connect the router at all. Just changed the router so that it permanently connects at Channel 10.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.