Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with some web sites where the first time I hit the site, the web browser says "connecting" and then it will time out. If I hit the site again, it will load just fine. If I browse around the site, it will work fine as long as I keep browsing, but if I wait a while, it will time out again. Qwest was no help with this - they sent me a new modem, which made no difference. Most sites work fine, but one of my favorite sites doesn't - it is a forum site, so I often will type a message and then have the site time out... seems like it only stays alive for a minute or so, and then my computer loses track of it.

I'm using Vista Home Premium, Qwest DSL with Actiontec PK5000. This problem also happens on my two XP Pro machines. It is completely repeatable with the sites listed below... all I have to do is wait one minute, then the site will time out again. If I hit the site on one computer, it will come back to life on all the machines in the house - two are on direct connections to the modem and one is on wireless. I have tried Firefox, IE, and Chrome. The problem is not browser related, computer related, or modem related - it has to be something in the network. Please help! So I can call Qwest and tell them what this is.

http://www.helifreak.com/

http://www.livingproof.com/

EDIT: tried the Google DNS and it didn't work

share|improve this question
    
Try Wireshark. It tells you everything that happens on your network. It is a lot of data, but you can use filters to check for certain types of requests. –  Eugene Feb 12 '10 at 19:24
    
Try Wireshark. It tells you everything that happens on your network. It is a lot of data, but you can use filters to check for certain types of requests. You could also try a different ISP if available in your area (via cellphone maybe). This will help you determine if your ISP is messing you up. Or you could also try a different OS (get one if those live Linux discs and load from it). This might tell you if it's OS-specific, even though you used two different versions of Windows. –  Eugene Feb 12 '10 at 19:30
    
Sorry for double-post. I am on an iPhone, don't know what happened. –  Eugene Feb 12 '10 at 19:31
    
After over a month of having this problem... it suddenly went away. So maybe some automatic error tracking picked it up and they fixed it. I don't know. I hate it when that happens. –  Jasmine Feb 13 '10 at 20:08
add comment

3 Answers 3

up vote 1 down vote accepted

Your ISP may be having some DNS issues... What could be happening is when your browser makes a DNS (Domain name) request to the OS for the remote servers' IP address, and the browser's request is timing out before it gets a response. But when you hit reload, the DNS entry is there because while your browser timed out, the OS's DNS request didn't... or maybe the 2nd time it goes faster because the ISP DNS servers had it in cache.

Try setting your DNS to google's DNS servers or OpenDNS.

share|improve this answer
    
That is kinda what I was thinking, but an hour on the phone with Qwest tech support could not convince them of that. I told them it was something wrong with their DNS, but they acted like they didn't know what I was talking about. I'm a programmer, not a network expert, but it ticks me off that the person I call who is supposed to be a network support tech doesn't know what I'm talking about. –  Jasmine Feb 12 '10 at 4:04
    
well, the customer service people are barely able to follow the script given to them to fix your computer, much less know anything know about the internal workings of their networks. I've worked at an ISP before and they typically don't have the best staff running the network. –  Roy Rico Feb 12 '10 at 4:17
    
The Google DNS didn't make any difference. Is there any way I can figure out what happens out on the network when I make the request? –  Jasmine Feb 12 '10 at 5:01
add comment

If you have multiple computers at the same location, could it possibly be that your router is not set up properly?

share|improve this answer
add comment

I had the exact problem this week, it turned out it was caused when I enabled DHT and PEX on my BitTorrent client (Transmission). It seems that this led to my network being flooded with external requests.

You could maybe try looking at the logs on your modem and seeing what the volume of incoming requests is like.

You could also look at the firewall settings (if you have one) and try disabling all incoming requests.

share|improve this answer
    
I don't have any unusual activity in the modem log, and incoming traffic is mostly blocked. –  Jasmine Feb 12 '10 at 4:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.