Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The computer does not seem do know that there is an SD card in the reader. The reader is showing up in Device Manager and I tested the SD card in another computer (it's fine).

It's a Dell Vostro 1500 running WinXP Home. Thoughts?

share|improve this question

migrated from serverfault.com Feb 12 '10 at 7:12

This question came from our site for professional system and network administrators.

4 Answers 4

Does your card reader appear as a drive letter in My Computer? If not, you may just need to right-click My Computer, select Manage, open Disk Management, right click the card reader in the list and assign it a drive letter.

Try uninstalling and deleting the drivers from within device manager. Then re-download the drivers for the Ricoh R5C833 card reader from Dell's website and re-install. My link should bring up the drivers specific to your laptop.

It may also be worth checking that the 'Allow the computer to turn off this device to save power' setting is unticked for the card reader. You can find this setting on the Power Management tab once you have opened the properties for it in device manager.

Failing this, if your laptop is still under warranty - contacting Dell technical support is the next best option. The chat to a technician feature is worth looking at, not sure if they cover Vostro's though - you need to enter your service tag number first to find out.

share|improve this answer
    
I didn't notice this answer (note to self: Refresh open webpage ever so often!) before, otherwise I would have tried it. As it is, it's working now, but thanks for the tips! –  ssvarc Feb 12 '10 at 10:21

It would help to know what make and type is this card reader, because some of them need an installed driver or are formatted in an exotic manner (although this is quite rare - almost all of them work with the XP built-in drivers).

Also, if the card reader came with a software CD, it might be a good idea to install it.

If this is a USB card reader, you might also verify that your USB hub or whatever is functioning correctly by using another device.

share|improve this answer
    
It is the built=in Dell Vostro 1500 card reader, just as the title says. It appears to be made by Ricoh. I've installed the drivers off the Dell site, and it appears in the Device Manager. The card itself is 4GB. –  ssvarc Feb 12 '10 at 11:08

Here's the answer for a similar configuration: Vostro 1710, Windows 7 64-bit, needs the Ricoh R5C833 driver, got it from Dell Support R240788.

share|improve this answer
up vote 0 down vote accepted

I don't know what caused it but the card started to work again. Beats me what was wrong. Among the steps I tried (written up as a to-do):

  1. Make sure your card is working. Try it on another computer.
  2. Try another card on the original computer that is having the issue. These steps should eliminate a bad card from the equation.
  3. Check in Device Manager to see if your reader shows up there.
  4. Reinstall any drivers that might be connected.
  5. Make sure Windows is updated.

And then some of the combinations of readers. I have tried the card in:

  1. Built-in Vostro card reader
  2. Motorola USB SD Card reader plugged into the Vostro
  3. SanDisk USB card reader plugged into the Vostro
  4. The same SanDisk plugged into an Inspiron laptop
  5. Built-in Inspiron card reader.

Now it works. I guess that's good but it leaves me bewildered.

share|improve this answer
    
@Ssvarc: Sometimes Windows needs a couple of reboots to fully enable driver updates (or other changes). –  harrymc Feb 12 '10 at 12:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.