Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running on an overclocked quad-core to 3.6ghz. I've got a lot of fast ram and an SSD. My motherboard is top tier.

Yet, when my Firefox addons update, I have to sit here and wait several seconds (like 6 or 7 seconds) after they download. A big Visual Studio project loads faster than it takes the addons to update. I'm talking about even after they download, I have to wait 6-7 seconds for them to finish updating.

Is there an artificial pause in Firefox updates or something?

share|improve this question
2  
You can run the fastest computer in the world, you don't know what is done in this updating, it can easily be more expensive than loading your VS project. No reason for an artificial pause, it just takes that time to update, nothing to do about it, not much else to answer to that. –  Gnoupi Feb 12 '10 at 13:19
    
i don't care for 'fast ram' and 'top tier motherboards' (which is old junk next week anyway :). how about precise system specifications, the operating system and the Firefox addons you have installed? –  Molly7244 Feb 12 '10 at 15:37
    
I agree with Gnoupi. I don't think that time differs significantly between the lowest and the highest range of machines. Some things just take some time. But, why is it of any importance ? I mean, how often do they update ? –  ldigas Feb 12 '10 at 15:49
    
I find it a very interesting question. –  Cawas Mar 11 '10 at 20:53

3 Answers 3

up vote 1 down vote accepted

One simple solution is to go to Tools -> Options -> Advanced -> Update and Uncheck the auto-update for Installed Add Ons.

Probably the best solution would be to change the extension update interval: You can do so with extensions.update.interval . It is set by default to 1 week (86400 seconds)

share|improve this answer
    
prior to firefox 1.5 the default was 1 week 604800000 in miliseconds firefox 1.5 and above it is one DAY 86400 seconds. My own recent experience (with komodo and not firefox) is that is is using minutes. Buyer-beware –  user34019 Apr 26 '12 at 19:48

I just assumed that it was DNS lookups causing the delay.

I've actually reduced the quantity of add-ons simply because of this annoyance. Surely this could be done in the background....

share|improve this answer

A fast computer won't get the Internet faster... Maybe the site where the extensions are stored is busy or your browser is doing checks before letting you install an update

share|improve this answer
    
He mentioned "after they download". So it's not the download time, only updating. –  Gnoupi Feb 15 '10 at 8:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.