I just did an update of my Debian system on my vserver from lenny to squeeze as described here.
I got some errors during the install, saying that glibc couldn't be updated.
I did an
apt-get -f install, which gives me the following warning:
WARNING: this version of the GNU libc requires kernel version 2.6.18 or later. Please upgrade your kernel before installing glibc.
The installation of a 2.6 kernel could ask you to install a new libc first, this is NOT a bug, and should NOT be reported. In that case, please add lenny sources to your /etc/apt/sources.list and run: apt-get install -t lenny linux-image-2.6 Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.10.2-2_i386.deb (--unpack): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/libc6_2.10.2-2_i386.deb
I added these lines to my
deb http://ftp.de.debian.org/debian squeeze main contrib non-free deb http://ftp.de.debian.org/debian-volatile squeeze/volatile main contrib non-free deb http://ftp.de.debian.org/debian-security squeeze/updates main contrib non-free deb http://ftp.de.debian.org/debian lenny main contrib non-free deb http://ftp.de.debian.org/debian-volatile lenny/volatile main contrib non-free deb http://ftp.de.debian.org/debian-security lenny/updates main contrib non-free
Now I tried to install a newer kernel using this command:
apt-get install linux-image-2.6-openvz-686
Which leads to this error:
The following packages have unmet dependencies: libc-bin: Breaks: libc6 (< 2.10) but 2.7-18lenny2 is to be installed linux-image-2.6-openvz-686: Depends: linux-image-2.6.26-2-openvz-686 but it is not going to be installed locales: Depends: glibc-2.10-1 nscd: Depends: libc6 (> 2.10) but 2.7-18lenny2 is to be installed
What do I have to do to upgrade my kernel?