Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just did an update of my Debian system on my vserver from lenny to squeeze as described here.

I got some errors during the install, saying that glibc couldn't be updated.

I did an apt-get -f install, which gives me the following warning:

WARNING: this version of the GNU libc requires kernel version 2.6.18 or later. Please upgrade your kernel before installing glibc.

The installation of a 2.6 kernel could ask you to install a new libc first, this is NOT a bug, and should NOT be reported. In that case, please add lenny sources to your /etc/apt/sources.list and run: apt-get install -t lenny linux-image-2.6 Then reboot into this new kernel, and proceed with your upgrade

dpkg: error processing /var/cache/apt/archives/libc6_2.10.2-2_i386.deb (--unpack): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/libc6_2.10.2-2_i386.deb

I added these lines to my /etc/apt/sources.list:

deb squeeze main contrib non-free
deb squeeze/volatile main contrib non-free
deb squeeze/updates main contrib non-free

deb lenny main contrib non-free
deb lenny/volatile main contrib non-free
deb lenny/updates main contrib non-free

Now I tried to install a newer kernel using this command:

apt-get install linux-image-2.6-openvz-686

Which leads to this error:

The following packages have unmet dependencies:
  libc-bin: Breaks: libc6 (< 2.10) but 2.7-18lenny2 is to be installed
  linux-image-2.6-openvz-686: Depends: linux-image-2.6.26-2-openvz-686 
  but it is not going to be installed
  locales: Depends: glibc-2.10-1
  nscd: Depends: libc6 (> 2.10) but 2.7-18lenny2 is to be installed


What do I have to do to upgrade my kernel?

share|improve this question
up vote 3 down vote accepted

I guess the kernel upgrade isn't possible because I'm running a virtual machine inside a virtual server (openvz).

I think for a kernel upgrade the server itself has to upgrade the kernel.

share|improve this answer
ahh. this would have been important info to add to the initial question. yes, you can't upgrade a VPS' kernel -- you have to upgrade the server's kernel. – quack quixote Feb 13 '10 at 16:55
I had the same problem at a VM on while upgrading from squeeze to wheezy but the server has kernel 2.6 installed. I had to move to a new VM on a mashine that has a newer kernel – rubo77 Jan 4 '15 at 12:09

I guessed that you couldn't upgrade because you were working within a vps, and you discovered that yourself. It is possible to run different versions of the kernel on a vps from the server root, but that can only be done from the root.

See my question Debian Lenny expects udev on a vps that doesn’t support it: even though Debian might complain about some unmet dependencies, you might still have introduced code that depends in some way on the higher version of Linux you haven't got: check to see if udev is installed; there might be others.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.