Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Vista service pack 1 and whenever I open the Firefox browser before opening other browsers my Internet slows to a crawl. Using my download speed is ~10Mb/s with just Firefox open but when I open Chrome or IE8 after Firefox is open the connection speed drops to ~0.2Mb/s. If I close these browsers while the speed test is going on the speed will jump back up to ~10Mb/s The funny part is if I open IE8 first and do the speed test in IE8 it doesn't matter if Firefox is open. The connection speed remains ~10Mb/s regardless of what I do.

I have a feeling the other programs slow down the connection too. I usually have 2-3 instances of putty.exe open and various other programs like iTunes. The description above is the simplest steps to reproduce the problem 100% of the time.

I used wireshark to see if there was a program eating up bandwidth and I didn't see any unusual traffic. I am using a linksys wireless g pci network adapter and my connection to the wireless access point is always 54 Mbps or 48 Mbps. I updated the drivers for this card and the problem still occurs. I disabled windows firewall and I am not running any other firewall software. I tried googling for a solution but the only thing I could find are general complaints about vista's networking speeds.

share|improve this question

After some more trials I found that when the second window that opened was dragged off of my third monitor the speed test would improve dramatically. This monitor is run off a second video card in a PCI slot. Both video cards are nvidia 8400 gs. Disabling this monitor completely solves problem.

I guess it is a problem with the video card or more likely the driver.

share|improve this answer
+1, nice bit of sleuthing. – quack quixote Feb 23 '10 at 1:58

Which version of Firefox are you using?

Maybe you should disable a few extensions of Firefox and check again.

share|improve this answer

You must log in to answer this question.