Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I do a lot of copy/pasting of paths in Terminal for svn commits, and I've noticed some strange behavior that I can't quite seem to track down. I use cmd-shift-double-click to select the full path from an svn status, and then hit cmd-c and cmd-v in sequence to copy and paste the path into an svn ci that I'm building up. The problem, though, is that sometimes when I hit cmd-c, the computer produces a "click" sound, and instead of copying the path I have selected, it pastes what's currently on the clipboard and send enter, causing my commit to happen sooner than I want.

I can't reliably duplicate the behavior, and I have no idea what's causing it. I'm fairly confident it's not something like having the shift key held down when hitting cmd-c. I have LaunchBar installed with clipboard extensions, but I don't see any configuration options with a shortcut of cmd-c or cmd-v, and looking through my keyboard preferences doesn't suggest anything either. I'm really at a loss, and this sporadic behavior is driving me slowly crazy.

share|improve this question
    
The "click" sound is different from the error sound, right? (The error sound being the beep one heres when, for example, hitting Cmd-C with nothing selected.) And what is the reason for holding down Cmd-Shift while double-clicking? –  Arjan Feb 15 '10 at 21:00
    
Yes, the sound is different from the error sound. Holding down cmd-shift while double-clicking changes the selection behavior. Normally Terminal.app wont's select a full path when double-clicking, but if you hold down cmd-shift and double-click it will. I think the functionality was intended for opening links from the terminal, but it works well for this, too. –  user28104 Feb 16 '10 at 18:49
add comment

2 Answers 2

up vote 0 down vote accepted

I also have LaunchBar installed and it would occasionally do the same thing using cmd-c anywhere. To solve this I switched off 'Enable ClipMerge' in preferences. I don't know why it does this, it just does.

alt text

share|improve this answer
    
I'm pretty sure this is the problem, and I've gone ahead and disabled ClipMerge, which I never intentionally use anyhow. Thanks! –  user28104 Feb 16 '10 at 18:46
add comment

First try to remove LaunchBar with clipboard extensions and see if the problem goes away. If it does, complain to the developer. If it doesn't, try getting a new keyboard.

share|improve this answer
    
As for a new keyboard: what erroneous keystrokes could the current keyboard be sending that explains the behaviour? –  Arjan Feb 15 '10 at 20:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.