Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Can you force Firefox to let a “not compatible” plug-in run? — MileWideBack

I updated to Windows 7 Pro (from Vista) last night, and after re-installing Firefox, found that the extension I use the most (and practically rely on) is not working (it is "compatible" according to Firefox, just not doing anything). MileWideBack basically turns the far left of the screen into a giant Back button (which also allows tab switching and closing using a mouse wheel). I've used this extension for about 4 or 5 years now (I think) so being stuck without it is quite a pain.

The page at says that the extension hasn't been updated since October 2006, so I'm not hopeful for a fix to come out any time soon. Also- one other reviewer says that they're experiencing a similar problem (on Windows 7 Ultimate). I've tried disabling all other extensions to see if there were any conflicts, but it hasn't worked.

I'm wondering if anyone knows WHY this is happening with Windows 7, and if anyone has any ideas how to go about fixing it? If not, I'm thinking it might be easy (ish) to replicate it (maybe using Jetpack) and would appreciate any pointers on how to go about doing that...

share|improve this question

marked as duplicate by Robert Cartaino, Troggy Feb 14 '10 at 4:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

@Dt7 - This is a duplicate of the question linked below. I had the same exact problem and got a fix here. Check it out - Can you force Firefox to let a “not compatible” plug-in run? MileWideBack -… – Robert Cartaino Feb 13 '10 at 15:15
Firefox is saying that the extension is compatible, it's just not working. I've set both of those variables just in case, but it's still not working... – Chris Feb 13 '10 at 15:23
After upgrading, Firefox 3.6 said that this extension was not compatible, so it was disabled. With the changes listed in the "accepted" answer, the add-on is running just fine. – Robert Cartaino Feb 14 '10 at 19:43
up vote 1 down vote accepted

Solved it- had to uninstall Firefox 3.6, then install 3.5.7, install the extension, then upgrade back to 3.6. Somehow, that works.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.