Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Mac Mini is capable of 802.11a/b/g. I have an Airport Extreme that is capable of 802.11a/b/g/n. The Mini connects at only 802.11a. It is close and has a very strong signal. How do I push the Mini to reconnect at 802.11g?

Update: I'm using Airport Utility version 5.5.x.

share|improve this question
    
I have no experience with Airport Extreme, but can you disable 802.11a/b ? – Felix Feb 14 '10 at 10:08
    
Update: I called Apple. Their tech showed me how to do what Kami suggested (albeit with Airport Utility 5.5 which has a slightly different interface). My Mini immediately jumped to 802.11g. Awesome... Thank the tech and on my way to speedier surfing... Later in the day I lost my connection. No matter what I could not reconnect even though the Airport was listed with a strong signal. Looking in the console I see an unexplained error. So I get my 16' CAT5, and change the setting back. Airport connects immediately, no problem, at 802.11a. <Sigh> – dacracot Feb 16 '10 at 16:36
    
I don't understand why you'd want to switch to B/G when you can do A. A and G have the exact same rate set, just in different bands. 802.11a works in the generally less-noisy 5GHz band, whereas 802.11g works in the noisier 2.4GHz band same as 802.11b. – Spiff Dec 15 '11 at 8:39

You can disable "a" mode in your Airport Extreme !

Air Port Utility -> Your AE -> Manual Setup -> Wireless -> Radio Mode

alt text

To check what wireless mode your Mac mini is using, click at the wireless icon (top right of your screen) while holding alt :

alt text

Finally go to System Profiler -> Network -> Airport -> Supported PHY Modes to ensure Mac mini supported modes

share|improve this answer
    
Since the Mini can not communicate at 802.11n, this would be a bad idea. – dacracot Feb 14 '10 at 19:21
2  
802.11n (b/g compatible) !!! – Kami Feb 14 '10 at 19:23
    
Doesn't it say so in the images? – Ivo Flipse Feb 15 '10 at 6:17
    
Ok, but my Airport Utility has different choices. I'm using version 5.5. It lists: Automatic, 802.11a/n - 802.11b/g, and 802.11a - 802.11b/g. I tried them all and the Mini connects at 802.11a. – dacracot Feb 15 '10 at 15:50
    
Have you updated your Airport Extreme ? – Kami Feb 15 '10 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .