Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem (using Mac OS X 10.5.8) with the access rights of a folder that was presumably created by a virus on a disk-on-key drive when I used it with a PC. I can't remove the folder or change it's name. In Finder's Info window the Lock box is unchecked and uncheckable - if I try to check it it flips back to off.

Please see the details:

MaxBookAir:GARMIN'S maxint$ rmdir winamp_cache_0001/
rmdir: winamp_cache_0001/: Operation not permitted
MaxBookAir:GARMIN'S maxint$

MaxBookAir:GARMIN'S maxint$ mv winamp_cache_0001 test
mv: rename winamp_cache_0001 to test: Operation not permitted
MaxBookAir:GARMIN'S maxint$

MaxBookAir:GARMIN'S maxint$ GetFileInfo winamp_cache_0001
directory: "/Volumes/GARMIN'S/winamp_cache_0001"
attributes: avbstclinmedz
created: 12/23/2009 14:34:52
modified: 02/13/2010 22:52:36
MaxBookAir:GARMIN'S maxint$

MaxBookAir:GARMIN'S maxint$ stat  -x winamp_cache_0001 
  File: "winamp_cache_0001"
  Size: 32768        FileType: Directory
  Mode: (0777/drwxrwxrwx)
  Uid: (  502/  maxint)
  Gid: (   20/   staff)
  Device: 14,5   Inode: 7439    Links: 1
  Access: Wed Dec 23 00:00:00 2009
  Modify: Sat Feb 13 22:52:36 2010
  Change: Sat Feb 13 22:52:36 2010
MaxBookAir:GARMIN'S maxint$

MaxBookAir:GARMIN'S maxint$ stat -r winamp_cache_0001  
234881029 7439 040777 1 502 20 0 32768 1261506600 1266081756 1266081756 1261559092 131072 64 32768 winamp_cache_0001
MaxBookAir:GARMIN'S maxint$

MaxBookAir:GARMIN'S maxint$ ls -lTd winamp_cache_0001/
drwxrwxrwx  1 maxint  staff  32768 Feb 13 22:52:36 2010 winamp_cache_0001/
MaxBookAir:GARMIN'S maxint$
share|improve this question

2 Answers 2

Possibly a dumb question, but what filesystem is the flash drive formatted with? If it's NTFS and you don't have MacFUSE installed with the NTFS-3G driver, then you can only mount NTFS drives read-only. (Unless you enable the experimental r/w NTFS support, but it seems to be very unstable so I would not recommend it).

If you're sure the disk is not mounted read-only (you can check this in Disk Utility → Info → look for "Writable"), then try deleting this directory with sudo:

sudo rm -r winamp_cache_0001
share|improve this answer

You don't need to install MacFUSE, just follow this to read/write your NTFS partition, then remove the directory.

share|improve this answer
    
This is interesting and I had not heard of it, but given the multiple mentions of instability and filesystem corruption, I'd probably suggest sticking with NTFS-3G. See this article for references of it causing problems: macosxhints.com/article.php?story=20090913140023382 –  Stephen Jennings Feb 13 '10 at 21:38
    
I tried it once and it worked. I suggest this, because he only needs one time access to the hard drive. –  Studer Feb 13 '10 at 21:47
    
The disk proved to have FAT16 filesystem, so I'm confused. –  maxint Feb 15 '10 at 14:08
    
Then try with sudo rm -rf winamp_cache_0001. –  Studer Feb 15 '10 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.