Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For most of my document writing I use iWork Pages (from iWork '09), and it's usually fine for me. I don't miss Microsoft Word, except for one simple feature: the ability to number chapter titles and paragraph headers for easy reference in the contents of the document and for cross references.

Somehow, I cannot find this feature in Pages '09. It is possible to number headers by setting the style to numbered, but it doesn't mitigate well into the generated dynamic contents, and paragraphs don't follow the numbering of higher level elements it seems.

Does anyone know how to make this work?

share|improve this question
add comment

2 Answers 2

up vote 8 down vote accepted

I've always used the numbered style, it's a little quirky, especially when it comes to the table of contents, but it does ultimately work. What documents are you ultimately creating that don't obey the numbering rules?

To do a 2 tier numbering scheme:

  • Set the "Heading 1" style to "Numbered List"; right click on Heading 1 to save the style.
  • Set the "heading 2" style to "Numbered List"
  • Open the inspector palette, choose "text inspector" and then the "list" tab.
  • Change "numbers" to "tiered numbers"
  • Select "continue from previous"

It is not perfect and requires more setup than I'd like, but I have successfully formatted 100+ page documents using this. The net result should be something like this:

Pages with tiered numbers.

share|improve this answer
1  
I have followed your instructions, they are very much like what I have tried before. Some observations: * Numbered style does not affect table of contents * Heading two needs to be manually "pushed to the right" every time, else it will screw up numbering. + 1 for your excellent guide, but it is not the answer I am looking for. –  dyve Jul 22 '09 at 18:08
    
I ended up mirroring the styles when setting up my TOC. You do have to many sure that the "indent level" is correct, but if you're just looking for the text itself being flush left, you can use the text indent box. IMO the whole numbering system is pretty serious deficiency in Pages, (of which there are many, I must say). –  David Snyder Jul 22 '09 at 18:29
1  
It does seem there's nothing better than your solution, so I'll mark it answered. Thanks for your input. –  dyve Jul 23 '09 at 3:18
add comment

Your question is my question, but I "solved" my problem with less fuss. Just put the heading numbers in the heading text manually! If you include an auto-ToC in your doc, it is very easy to check in a single saccade that the numbering is correct.

Yeah, one shouldn't have to do that. I wish Apple thought so too. I switched to writing fullscreen in Pages from LaTeX because the formatting commands in LaTeX were getting in my way . I'll probably port my writeup to LaTeX once it is finished first in Pages. This is probably the sole reason I'll switch back to LaTeX.

share|improve this answer
add comment

protected by Troggy Jul 14 '11 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.