Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a mysterious problem with my XP laptop. Since a) installing the latest windows updates and b) using Picasa 3.6 to look through dozens of GB of photos for faces, it now takes ages (first time: 45mins, second time: 10 mins) to get from login to a populated desktop. The whole time the hard drive light is on.

I am also experiencing odd freezing of the UI - in a context menu, or trying to start Access Connections, the window may freeze and no longer redraw until I eventually kill it off with the task manager (which may also take several minutes to respond). Other things seem fine; Firefox is working as usual, for example, although the first time it took 30 minutes until the WiFi was recognised :/

I have tried uninstalling the dodgy windows update, which has not helped. Could it be Picasa slowing me down? if so, is there a service I should stop or something? Any ideas would be much appreciated!

share|improve this question
  • check your event log.

  • use Bootvis to find the culprit(s).

  • use Autoruns to disable the programs causing the delay (and other unwanted/unnecessary programs).

share|improve this answer
Thanks; How do I check the event log? – Joel in Gö Feb 14 '10 at 0:52
oh, ok, it tells you how here: – Joel in Gö Feb 14 '10 at 0:55
And you can use Process Monitor or Process Explorer (both from Sysinternals) to discover which process is using the disk so much. – njd Feb 14 '10 at 0:58
According to the event log, SQLServer is doing all kinds of crap. I never knowingly installed the damn thing; it may have come with VisualStudio, but has never caused trouble before... – Joel in Gö Feb 14 '10 at 1:09
@Joel in Gö - something must have triggered it going berserk. – Molly7244 Feb 14 '10 at 1:35

The answer was actually to ininstall ThinkVantage Access Connections (the Thinkpad WiFi utility). No idea why it started playing up so badly.

The first answer is more useful in general though, so I won't tick this as the accepted answer.

share|improve this answer
Nothing wrong with accepting your own answer as correct if it solved the problem :) – Molly7244 Feb 15 '10 at 23:40
You might actually edit your original question, since poor old Picasa doesn't seem to be the culprit. :) – Molly7244 Feb 15 '10 at 23:45
good point =:o) – Joel in Gö Feb 16 '10 at 7:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .