Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have working apache/php/mysql on my Gentoo server. But I have to enable some extensions in php (json, exif).

I did:

USE="dev-lang/php json exif" emerge dev-lang/php

Please, tell me what next?

Thanks!

share|improve this question
add comment

migrated from stackoverflow.com Feb 14 '10 at 1:25

This question came from our site for professional and enthusiast programmers.

1 Answer

Don't include the category/package name in USE, it's just

USE="json exif" emerge dev-lang/php

But I'd suggest making that choice persistent, e.g. by adding

dev-lang/php apache2 json exif

to /etc/portage/package.use and then

emerge dev-lang/php

all modules are built into the php executable, gentoo doesn't use extension modules (.so), so this should be all you have to do. Make sure the emerge exits without errors.

share|improve this answer
    
Thanks, I added these lines to /etc/portage/package.use and than, emerge dev-lang/php Do I have to rebuild PHP? I restarted apache but I still don't see json enabled... –  ipx Feb 14 '10 at 1:04
    
You are rebuilding php with emerge dev-lang/php. Use emerge -pv dev-lang/php to check the use flags. –  VolkerK Feb 14 '10 at 1:09
    
The one and only right answer, plus helpful comments. –  Benjamin Bannier Mar 11 '10 at 17:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.