Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using mobile dial up on ubuntu.

However, SOMETIMES even though I am connected to the ISP, I do not have any entries in /etc/resolv.conf. I often restart network-manager or networking hoping it will change but normally it doesn't do any good. and by connected I mean I can see that the network notification icon has switched to a few bars indicating connectivity).

Anyone know a good solution around this?

share|improve this question

migrated from stackoverflow.com Feb 14 '10 at 9:16

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Make your own /etc/resolv.conf with publicly accessible DNS servers. For example, you could create a file /etc/resolv.conf.opendns with contents

nameserver 208.67.222.222
nameserver 208.67.220.220

and then

cp /etc/resolv.conf.opendns /etc/resolv.conf

to have your system use the OpenDNS servers. Of course, this doesn't tell you why the /etc/resolv.conf file is empty, but it should enable your machine to use DNS to resolve names.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.