Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using the beta 2010 Office Outlook. When I try receive or send, I get the following error.

Outlook data file cannot be accessed.

Repairing and reinstalling Office and trying to use any different Outlook data files are not taking any effect.

share|improve this question
    
Check your Outlook data file: pst, perhaps create a new one in the options. –  Zyphrax Feb 14 '10 at 13:57
    
Just create a new datafile and import your old one into it. Simple! –  user42251 Jul 8 '10 at 8:56
1  
Jim S's solution worked for me. I chose change folder and had the email deliver to my Inbox. It was previously pointing to my Archive folder. –  user62205 Jan 10 '11 at 13:36
    
Andy Chips solution worked for me. –  Mitch Wheat Jan 7 '12 at 4:51
add comment

migrated from stackoverflow.com Feb 14 '10 at 14:09

This question came from our site for professional and enthusiast programmers.

6 Answers

STOP!! Before you bother creating new PST files/importing PST files or other laborious tasks, PLEASE READ THE FOLLOWING....

Take a look at where each of your email accounts is delivering mail. I think you'll find that after migrating to Outlook 2010 or Windows 7, the location is missing. So here are two fixes that will depend on your situation.

  1. Click File (top left)/Account Settings. Select an account. If you're lucky, you can simply click the button that says Change Folder, select where you want the mail delivered and your done!

  2. If you not that lucky as was the case with me, you will have to recreate each account with one important adjustment from what you are accustomed to (I had 6 accounts to re-create, ugggh!). Delete and create each account one by one. When you're creating the new accounts select Manually Configure Server Settings and on the Internet Email Settings page you will see a box in the lower right corner that says "Deliver New Messages to:" New or Existing Outlook data file. Select Existing, Browse to your file location and select your data file. After completing the account set up process you should be in business!

Good luck!

share|improve this answer
add comment

Jim was on the money with this one, but FYI, there's no need to perform Step 2. Some of you (like me) have multiple accounts and the thought of re-creating each one is just far too much, especially as Microsoft have seen fit to get rid of the Office tool to backup and restore your Office settings. Anyway, here's how:

1. Create a new dummy PST using the same Account Settings window and Data Files tab. Add a new PST file - wherever you like (you won't be keeping it).

2. Go back to step 1 of Jim's instructions where you change the folder where the selected account delivers its email. Choose the new PST then click OK. Immediately go back into that dialog and change the folder location back to the original PST.

3. Do the same for each account, then once done, remove the temporary PST.

Job done. Hope that helps someone. Andy.

share|improve this answer
    
Could you paste a picture or list the steps in 1. Create a new dummy PST using the same Account Settings window and Data Files tab. I have Outlook 2010 configured on a number of client PCs to SBS 2008, however it looks like the main inbox is storing .OST files in Computer\C:\Users\myname\AppData\Local\Microsoft\Outlook. I thought the .OST data should be stored on the SBS 2008 server? –  user59470 Dec 17 '10 at 3:08
    
I spent 2 hours trying to fix this problem (MS sometimes your software sucks). This was the fix for me. How bloody fragile could outlook possibly be! –  Mitch Wheat Jan 7 '12 at 4:51
    
you sir are a legend! –  Dany Khalife Oct 13 '13 at 14:24
add comment

Choose a different folder WITHIN your Outlook datafile, click apply, and then change the delivery location back to the Inbox and click apply again. It is a simple solution, but it took me some time to find out:-)

Jim is right. However, for me this solution worked well.

share|improve this answer
    
+1 This is how I fixed it too. –  stevenvh Sep 9 '12 at 17:44
add comment

I was getting this error on my exchange account, and my account was also not able to sync the Inbox or Outbox. Changing the delivery location didn't help.

I went into the mail control panel, email accounts, selected my exchange account, and then clicked the "Repair" toolbar button.

I had to input my credentials a few times, but on next Outlook boot the problem went away.

share|improve this answer
add comment

If you are using Exchange it's easy:

  1. Go to your Outlook folder where the OST and PST files are.
  2. Delete the Exchange OST file and the OBI files.
  3. Then start Outlook again and that's it.

If you are not using Exchange, change the deliver location by editing your account settings.

share|improve this answer
add comment

Solution: Remove all old accounts and create new email accounts (not Outlook data file).

(To kez: I try to use any different Outlook data files, it's not take any effect. SCANPST does not take effect either.)

share|improve this answer
add comment

protected by Community May 11 '11 at 11:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?