Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently moved to the Czech Republic from Scotland and I can't find a way to permanently stop Google from automatically defaulting back to google.cz all the time. I've checked to ensure that all my google accounts and cookie based settings (e.g. Advanced Search Options) are set to English but it's still clearly doing an IP address lookup and disregarding everything else.

The default Search Engine for Google Chrome (and switches to google.cz automatically):

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s

I've tried hardcoding it to:

http://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s

this kind of works, but won't work for inline searching, i.e. I always have to press enter in order to get any results which is a bit annoying as I've gotten so used to AJAX style searching

I can't have been the only one to get this issue?

Any help is appreciated

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Try clicking the "no country redirection" link Go to Google.com on the main Google search page. My link should also do the same thing and may immediately fix your problem.

This is designed to be a toggle between the generic .com and local country-based page.

Some more information on this problem can be found here.

share|improve this answer
    
I should have noted that I had tried something similar to this by going to google.cz and clicking the 'Google.com in English' link. I read that if you click this link it sets a cookie (or maybe a Chrome setting) to default to .com, which it does now. As I've just carried out your method and the one I've mentioned I think both do the same thing. Thanks for the help –  Alex Feb 14 '10 at 17:33

I know this isn't an direct answer, but Google will be choosing the default location based on the geographic location of your IP address. As that is now in the Czech Republic it assumes that's what search portal you want.

One solution would be to use a proxy based back in the UK and access the internet through that.

share|improve this answer
    
It's funny that I had the exact same idea too, but I thought that was a bit of a crazy solution just to fix a relatively small problem. +1 for the abstract solution though :) –  Alex Feb 14 '10 at 17:37

I got a way for English.

Just create another customer search engine of Google. Use this URL: http://www.google.com/#sclient=psy&hl=en&safe=off&q=%s&aq=f&aqi=&aql=&oq=&gs_rfai=&pbx=1&fp=a20cfd04ba3c5cf9

and make it default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.