Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using VirtualBox on Ubuntu 9.10 with Windows XP as the guest OS. It's pretty annoying that when I in guest OS - I can't switch virtual desktops(workspaces) on the host(Ubuntu) by pressing ctrl+alt+(Left|Right|Up|Down) because of Virtual box captures these key combinations. Is it possible to disable keyboard capture for some key combinations ?

share|improve this question

While there are some Host Key shortcuts that activate certain VirtualBox functions (eg, Host Key+P which pauses the Guest), I don't know of any way to configure VirtualBox to send Host Key shortcuts to the Host OS.

However, since VirtualBox has an open source edition, it may be possible to modify the source code to add this feature. You can access the VirtualBox source code at the Download link.

In the meantime, you can use the Host Key to release the keyboard from the VirtualBox Guest's control. By default the Host Key is set to Right Ctrl. You can see the current Host Key in the VM window:

alt text

Just press the Host Key once to release the keyboard capture. After that, your Host OS will see your keypresses. So here's your workflow:

  1. Press and release the Host Key. Your Guest OS no longer captures keypresses.
  2. Press Ctrl+Alt+(Arrow key) to switch workspaces, or any other keys you want to send to the Host OS.
share|improve this answer
It would be nice...But [Left Ctrl]+[Alt] does not work too...It is not depends on host key at all, VBox captures all key presses. – Alexander Smirnov Feb 14 '10 at 18:41
i'm sorry, i misread your question; i thought you had an Ubuntu guest on an XP host. updated the answer. – quack quixote Feb 14 '10 at 19:31
Ok, thanks, I hope I'll find time for a little investigation to add this feature – Alexander Smirnov Feb 14 '10 at 21:25

This question is old, but I found a better solution that probably didn't exist back then.

You can disable "Auto capture keyboard" in Manager window -> File menu -> Preferences -> Input:

enter image description here

This disables the automatic keyboard grabbing completely, so window manager keybindings are passed directly to it.

In this mode, the 'host' key has the opposite effect - it enables grabbing instead of disabling it.

share|improve this answer
The downside of this is that now you need to remember to enable keyboard capturing before you use things like Alt+Tab. Virtualbox really really needs a way to map and disable keyboard shortcuts inside the guest. – stackular May 13 '14 at 16:34
Works great! I fail to understand why this setting is not machine-specific though. – Franck Dernoncourt Nov 7 '14 at 18:36

Pressing the host key (right-ctrl) once appears to allow the next key combination to go to the host machine.

For me, this means I can hit right-ctrl, release, then hit windows+left-ctrl+left to switch desktops

share|improve this answer
This isn't actually disabling keyboard capture for some key combinations, this answer would be better as a comment. – Don't Root here plz... May 19 at 15:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.