Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a machine with a Pentium 4 CPU in it that I run as a server. I've used it for a long time with no issues. Recently it has been unable to run for more than about 3/4 minutes from a cold-boot before locking up. My syslog shows that my CPU is overheating badly.

Upon inspection of the case there was some small amount of dust, but nothing massive, and the problem continues despite a thorough cleaning (including removal of heatsink and CPU to check for anything at all that could be causing this).

I'm really stuck for ideas on how to diagnose what is happening. Any ideas much appreciated!

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

When you removed the heatsink, did you thoroughly remove all remnants of the old thermal paste and then apply fresh paste?

Is the fan spinning properly? Many Pentium 4 processors (especially later Northwood and Prescott models) depend heavily on proper cooling.

share|improve this answer
2  
emphasis on apply fresh paste - and not toothpaste as someone asked about the other day. –  pavium Feb 15 '10 at 0:35
add comment

Try lowering the CPU voltage in your BIOS a little bit - it helped a lot on my system for which I replaced thermal paste with fresh one and thorough cleaning without success. It runs much cooler now and is still stable.

But still keep an eye on dust and fans...

Update: Do a visual inspection of the mainbaord: Do the capacitors still look good? Bad capacitors cause voltage instability which can lead to overheating or the CPU freezing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.