Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When you exit full-screen in PuTTY, it goes back into a non-maximized state, regardless of whether it was maximized or not before going full-screen.

Is there a way to make it return to maximized mode, or even just return to the state it was in? Shrinking has the unpleasant side-effect of truncating long lines that had been displayed when maximized/full-screen.

share|improve this question

migrated from stackoverflow.com Feb 16 '10 at 2:04

This question came from our site for professional and enthusiast programmers.

    
if you can't find a workaround (or even if you can), consider checking the known-bugs list and file a bug with the PuTTY team if the behavior you describe isn't listed: chiark.greenend.org.uk/~sgtatham/putty/feedback.html –  quack quixote Feb 16 '10 at 3:19

1 Answer 1

up vote 2 down vote accepted

If you intend to always use PuTTY in the same 2 modes (maximized and full screen), you can set a constant size in the Window Preferences and then select Forbid Resizing Completely:

alt text

I'm not sure on your screen resolution, but you can play around with the columns and rows until it is the same size as a maximized window. Then ensure you check off forbid resizing completely and this window size will be restored when coming out of full screen mode.

Another solution is to use Autohotkey:

#ifwinactive ahk_class PuTTY
!Enter::
Send {Alt down}{Enter down}{Alt up}{Enter up}
Winmaximize
return
#ifwinactive

This will toggle between fullscreen mode and maximized mode. Script tested and working on Windows XP SP3 and Windows 7.

share|improve this answer
    
If I use the forbid resizing completely option, it seems I can no longer go into full-screen mode. The Autohotkey solution almost works, but goes through the "non-maximized" state before maximizing, which keeps the undesired side-effect of truncating long lines in the terminal. –  Ed Mazur Feb 16 '10 at 2:49
    
How about using the option When window is resized: change the number of rows and columns but also set your rows and columns very high so it appears maximized already? That way when you transfer out of full-screen it will still be large and not truncate the text. –  John T Feb 16 '10 at 3:03
    
That did the trick, thanks John! –  Ed Mazur Feb 16 '10 at 3:42
    
You're very welcome :) –  John T Feb 16 '10 at 3:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.