Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having trouble getting my Linksys router to forward traffic to my PC. I had it working recently.

I had brighthouse Cable internet hooked up to my router and was able to port forward traffic to my server on my PC, I just recently switched to a new service provider that uses a DSL connection, so when I switched I now have a new IP address, no big deal I though, so I updated my port forwarding to my new IP with the DSL. The problem now is when I go to my IP in a browser instead of accessing ym server, it is showing some sort of zyxel control panel which has something to do with my DSL service.

I am lost, any ideas how I can get my router to direct traffic to my server instead of some control panel related to myu connection?

I am using Windows 7

share|improve this question

migrated from serverfault.com Feb 16 '10 at 12:55

This question came from our site for system and network administrators.

    
By chance do you use internal IPs in the 192.168.100.x block? Many DSL and Cable modems use this IP range for their internal workings. –  Chris S Feb 16 '10 at 3:02
    
I am using my external IP, the port forwarding I setup seems to kind of work except it loads some sort of CP from my service provider instead –  jasondavis Feb 16 '10 at 3:04

2 Answers 2

up vote 2 down vote accepted

Your new DSL modem is essentially providing the same functions as your Linksys gateway (it's already doing NAT and firewall stuff before the packets even hit your Linksys). You have two choices, both which require your to edit settings in your DSL modem:

  • Configure the NAT settings you need directly on the DSL modem.

  • Configure the DSL modem to operate in bridged rather than routed mode.

Option #2 is the preferable choice because you'll be able to continue using your Linksys as previously configured. However, depending on the device, you may not be able to configure it in bridged mode. If that's the case, you'll have to go with option #1.

share|improve this answer

When I switched from cable to DSL, I had to put the DSL modem in bridge mode AND switch the base address of the router to 192.168.200.x. So, both of the above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.