Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer work behind a squid proxy with authentication. After doing several configurations, many programs still does not use the proxy settings. I configured the ubuntu proxy settings, inthe .bashrc and the /etc/environment

I have looked at proxychains, but that is only for individual programs.

My thought is to use a desktop proxy like tinyproxy, and use ip tables to redirect all port 80 traffic to that proxy, which then goes to the external squid proxy.

This must be an every day problem.

share|improve this question

migrated from stackoverflow.com Feb 16 '10 at 14:37

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Have you tried the Network Proxy applet of Ubuntu? Go to System > Preferences > Network Proxy. Select the option Manual Proxy Configuration and add your proxy URL and port. Click the Details button and add the username and password. Click close.

I find this works for most apps in Ubuntu, graphical and command line. In Firefox. for instance, click Edit > Preferences, then Advanced tab and the Settings button. Select the Use System proxy settings.

HTH

Angus

share|improve this answer
    
There's no spot for usernames or passwords though. Is that prompted on demand? –  lowerkey Jul 6 '12 at 8:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.