Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

when I'm using Ctrl-] to jump to a tagname in vim it ignores ! and ? characters which can be used in ruby as parts of identifiers. i.e. when trying to jump to 'empty?' tag it complains about missing tag 'empty'.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Add the desired characters to the iskeyword option. Try:

:set iskeyword+=!,?
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.