Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running kubuntu 9.10 w/ gnome, I have a static IP defined in /etc/network/interfaces

When I unplugged my network cable and rebooted, then reconnected the network cable I was not able to connect. I tried using sudo ifup eth0, and then ifconfig and it seemed as though the IP address had been assigned and I was connected, but I wasn't. I then did ifdown eth0, and again ifup eth0. For some reason I'm not able to access the network. Furthermore, I also attempted to connect via wlan, and was able to connect to the wireless network, but cannot "see" the network. I can't transfer data or access the internet or anything on the network including the router.

How do I resolve this?

topsy@monolyth:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1c:25:1c:df:70  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::21c:25ff:fe1c:df70/64 Scope:Link
          RX packets:5720 errors:0 dropped:0 overruns:0 frame:0
          TX packets:565 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:378035 (378.0 KB)  TX bytes:46832 (46.8 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

By access the network I mean the local network as well as the internet.

topsy@monolyth:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=9.14 ms
64 bytes from icmp_seq=2 ttl=64 time=1.24 ms
64 bytes from icmp_seq=3 ttl=64 time=1.01 ms
64 bytes from icmp_seq=4 ttl=64 time=1.00 ms
[snip... all OK, icmp_seq from 5-30, time between 0.981-1.25ms]
--- ping statistics ---
30 packets transmitted, 30 received, 0% packet loss, time 29035ms
rtt min/avg/max/mdev = 0.971/1.300/9.140/1.458 ms

topsy@monolyth:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0 eth0
link-local      *          U     1000   0        0 eth0
default         UG    100    0        0 eth0

root@monolyth:~# cat /etc/resolv.conf
# Generated by NetworkManager
share|improve this question
the ping output shows you are accessing the local network; what exactly isn't working? – quack quixote Feb 17 '10 at 8:15
up vote 0 down vote accepted

Try this:

> sudo /etc/init.d/networking restart

If this does not help, check that the cable is "really" plugged - i.e. do the lights on the interface and on the switch/router are lit on.

Please, also, post as part of the question the output of these commands:

> ifconfig

> ping

> cat /etc/resolv.conf

> route
share|improve this answer
I have tried your suggestion, but to no avail. I added my ifconfig. The network lights both on the laptop and the router for that network cable are on. – Alex Feb 16 '10 at 21:33
Can you ping Oh, and btw, pls edit your answer once more, unfortunately I don't have enough rep to do it. Mark all the ipconfig output, and click on the smal icon with 1s and 0s above the edit window. this will mark it as "code", and will format it properly for display. Before saving the edit, check the output, so you see how it looks. Cheers. – Sunny Feb 16 '10 at 22:44
I also added in my answer some more commands for you to show the output. Looks like the interface itself is working, so the problem should be either DNS, or routing. Pls, also define "access the network" - the local network, or Internet. – Sunny Feb 16 '10 at 22:48
I have added the information you requested. – Alex Feb 17 '10 at 8:00
From what you post, you can access local network. So, pls, re-phrase your q. to tell us what exactly is not working. – Sunny Feb 17 '10 at 20:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.