Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Fedora Core 12 quad-core Linux box. However, when I run VMWare Workstation (running a single virtual XP box, running nothing) it slows to a crawl. The load average jumps from 0.11 to 4 or even 7 when I am using the virtual box. The mouse stops responding within the virtual box, and even on Fedora itself when the load average gets high enough.

I can't get any work done and I can't get into "the zone". Any ideas for fixes?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Do you have the VMware tools loaded in your VM? That would probably help. How much memory does your system have? How much memory and how many CPUs does your VM have allocated to it? Is your system doing anything other than run slow when you run your VM? (Does it start swapping more, does disk I/O go up considerably?)

share|improve this answer
    
I just upgraded VMWare tools, and it seems to help a little. The VM only has 512MB allocated to it, and I can't find a way to change it (am I just missing it?) I've added a Disk I/O monitor to check. As for swapping within Windows... it should turn up in there, right? –  calico-cat Feb 17 '10 at 2:48
    
@calico-cat: You can change the amount of RAM in the virtual machine's settings. I believe @baumgart is right, it sounds like your machine is swapping. How much RAM does the physical host have? What is your iowait% in Fedora when running XP? –  Josh Feb 17 '10 at 3:15
    
@Josh I'd love to be able to increase the RAM in the VM, but the RAM settings are all greyed out. Any way to unlock them? –  calico-cat Feb 17 '10 at 8:18
    
@calico-cat: the RAM settings can not be changed if the VM is running or paused - you need to completely shut down the guest OS then go back to the settings and you should be able to change them. –  David Spillett Feb 17 '10 at 10:33
    
It looks to be a hardware issue. There was minimal disk I/O, no swapping, and no processes were using up lots of resources. –  calico-cat Feb 18 '10 at 11:00
add comment

As well as the things to check that baumgart mentions, if Workstation is anything like WMWare Server there will be host "helper" modules for the host kernel that all more efficient operation of virtual hardware - make sure you have these installed (you need to recompile them after kernel upgrades, so you might have had them before but find them disabled now).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.