Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ripped a number of CDs into iTunes. I noticed that several of the tracks do not play, and they list "Not available" in the Time column of the track list. The file exists on disk, but it will not play in QuickTime either. I assume that some sort of file corruption has happened, but why are there so many? Is there a known issue that causes this, and is it preventable? How do I fix it without deleting the whole album and re-ripping it? This has happened on a number of albums.

OS: Windows XP SP2
iTunes: 9.0.2.25
QuickTime: 7.6.5

share|improve this question
2  
Is there any pattern to the corruption? e.g. is it always the first track, or last track, or tracks over a certain length? –  ChrisF Feb 17 '10 at 8:37
    
Good point! This didn't really stick out to me before, but although the corrupt tracks are not all contiguous, they tend to be clustered near the end in each case. Perhaps I have a wobbly CD-ROM drive. –  Jay Michaud Feb 20 '10 at 1:48
add comment

2 Answers

I would suggest re-ripping with alternative software - I know you said you didn't want to, but the files do sound corrupt. The Time field is generally not something held in the files tag, but calculated based on the encoding quality and file size. The fact that it's "unavailable" is just another reason to believe the files are corrupt.

If you get the same result with an alternative ripper, I might start to question the integrity of your CD/DVD drive.

share|improve this answer
    
or the hard drive integrity –  fluxtendu Feb 17 '10 at 9:00
add comment

I can think of two possibilities: Possibly CD drive problems such as bad motor, dirty lens, etc, possibly damaged/dirty.

The other possibility is that if you are running several other apps or otherwise putting a heavy load on the CPU during the rip, it can cause the data to not get encoded correctly, corrupting the file. While I haven't had this problem with iTunes, this has happened to me more than once while ripping with WMP.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.