Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The audio jack on the front panel of my HP TouchSmart IQ770 is not working correctly in Ubuntu (9.10 and 8.04). When I connect a headphone or a speaker to the jack, Ubuntu plays sound in both speakers - the default integrated speakers and the newly connected device. Vista mutes the integrated speaker and switches to the connected device, which is the behavior I'm looking for. This is not a 9.10 specific issue because I had the same issue with 8.04 too (and I couldn't solve it then).

I tried manually changing the 'Connector' option to 'Analog Headphones' (from the default 'Analog Output') in Sound Preferences|Output tab - but both the inbuilt speaker and headphones went silent.

I tried the workaround found here but it didn't work for me. I added options snd-hda-intel model=hp (tried model=auto too) to the /etc/modprobe.d/alsa-base.conf but that didn't work either.

Here are some info that (I believe) might be required to understand the issue.

$cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.20.

$lspci 
//among other things
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

$cat /proc/asound/cards
0 [NVidia         ]: HDA-Intel - HDA NVidia
                     HDA NVidia at 0xfbfb8000 irq 23
1 [SAA7134        ]: SAA7134 - SAA7134
                     saa7133[0] at 0xfebff800 irq 17

$/proc/asound/modules 
0 snd_hda_intel
1 saa7134_alsa

Can someone help me fix it?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

After hours of Googling and dozens or reboots, I got it working with the help of this post in ubuntu forums.

The solution is simple: add the following line to the /etc/modprobe.d/alsa-base.conf and reboot the machine.

options snd-hda-intel model=6stack

That line originally contained power_save, power_save_controller, position_fix and probe_mask variables along with the model variable that was set to auto. Sound did not work when I retained existing values for other variables and set model=6stack. I had to strip them off to get it working.

Hope this helps someone.

share|improve this answer
    
Actually this disables the system's inbuilt speaker no matter what - but at least I can use head phones without disturbing my colleagues. I am accepting this until someone comes up with a better solution. –  Amarghosh Feb 25 '10 at 6:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.