Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm adding the Event module to my fresh Drupal installation to get the calendar features on my site. The module shows up just fine in my modules page but when I click save settings I get the following error:

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to
allocate 24 bytes) in /var/www/church/drupal/includes/ 
on line 41

I have no idea what to do!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Your memory limit in PHP is too low. Here's how you may be able to increase it.

The standard PHP memory requirements for Drupal core are a bare minimum. Sites that run many contrib modules, or particularly memory-intensive ones, will need more.



This is the recommended approach if you have access to the server's php.ini. This will not be possible in some shared hosting environments, though your host may be able to adjust it for you. Note that this change will affect all websites and PHP scripts on the server.

  1. Locate the php.ini file used by your web server. You can click the "more information" link on Drupal's status page's PHP section. which shows the phpinfo() page. Locate the Configuration File (php.ini) Path row on that page. During installation Drupal checks the PHP Memory Limit, and if it is less than 32M (16MB for Drupal 6), an error message also provides the path to the php.ini file.

  2. Edit the memory_limit parameter in the php.ini file (usually in a section called Resource Limits) memory_limit = 64M ; Maximum amount of memory a script may consume (64MB) If there is no section already for this, place the above line at the end of the file.

  3. Restart Apache.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.