Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had this happen a couple of times - screen saver kicks in, locks the screen, and when I put my password in to unlock it the system just seems to hang.

Cursor turns to the busy, HDD light flickers occasionally, but the only thing I can do at that point is power down.

This is on a desktop, not a laptop and according to the bios all the power saving is turned off.

Has anyone else seen this? Is there a way to prevent it, or at least diagnose the cause?

share|improve this question
    
What are your system specs, particularly graphics card? I used to have this problem fairly often. I think I narrowed it down to use of the closed source ATI drivers on a cheapo Radeon I was using. It had the symptoms of a memory leak in the driver or xserver. It didn't happen with the open source drivers and it went away completely with my new Nvidia card. –  Joe Holloway Jul 22 '09 at 22:29
    
It's an N68 MB with an AMD chip, and an nVidia 9500 class card, using 180.x driver. I was having random hangs, but they were complete lockups - the mouse wouldn't even work, whereas with this, I can move the mouse. –  chris Jul 23 '09 at 1:38
    
I faced the similar problem in the older versions of Ubuntu . Which version of Ubuntu you are currently using ? –  ukanth Oct 6 '09 at 10:06

3 Answers 3

This seems to be a manifestation of a long standing issue with the nvidia drivers. Have a look at this bug report discussing an almost identical issue: screensaver locks up X. If it helps, you might want to try the PPA mentioned in the comments to see if you can find a more bleeding-edge driver.

Look at your /var/log files, specifically Xorg.0.log, syslog and messages, and see if you can spot any errors.

This has also been reported on the nvidia linux support forum in this thread (starting with the post by darksorceror) with a follow-up poll here.

No real solutions in there I'm afraid. If this is bothering you enough, may I suggest you file a bug-report on Ubuntu Launchpad.

share|improve this answer
    
Thanks Nagul! I had the exact same issue. It's comforting to know I'm not the only one. –  Mike B May 19 '10 at 21:11

This doesn't actually fix your problem but instead of powering down you could use Ctrl+Alt+Backspace

to end your X window session (you'll lose whatever you were working on, but hey at least you didn't have to reboot).

share|improve this answer
2  
That needs the DontZap option disabled as by default in recent Ubuntu distros, Ctrl+Alt+Backspace is disabled. –  staticsan Jul 28 '09 at 1:14
    
or instead of the DontZap you could use the new shortcut: superuser.com/questions/15961/… –  codeLes Aug 11 '09 at 2:15

I've seen this, or a similar event. I get a screensaver that doesn't even give me the password box.

It seems to be a few screensaver modules with a subtle bug. Molecule is one that I recall doing this. I just disabled the apparantly faulty ones. However, I've switched to xscreensaver from gnome-screensaver so I have that flexibiltiy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.