Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Specs to put things in context: AMD Athlon XP 2400+ @ 1987 MHz / 2 x 512MB PC3200 DDR RAM / WD 160GB IDE HDD / 3DFuzion 128MB GeForce 6200 AGP 4x / FIC AM37 / Windows XP SP3

Just recently, I was unable to start Windows Media Player. I clicked it and the busy cursor came up, but then nothing happened. Also, I tried doing a search for a file, and same thing. It would show busy cursor then suddenly stop doing anything. I couldn't find it in the Processes of the Task Manager. (Perhaps I don't know what I'm looking for?)

Also, I was trying to update my DirectX, which has been running something older than DX9 9.0c for a while now, except the installation fails due to "internal error".

I think the failed DirectX installation has been like that for a while... (I remember trying to install DX9 9.0c a while back, but still failed.) The Windows programs not starting, I don't think I've ever had before... what could be the cause of these problems?!

Thanks in advance. =)

EDIT1: Weird thing now is that when I try to open User Accounts, I get a message saying "Wrong number of arguments or invalid property assignment." Also, when I'm trying to open services.msc, I'm getting a script error that says that "Library not registered." (Code: 0, URL: res://C:\WINDOWS\System32\mmcndmgr.dll/views.htm) Perhaps this is related to my other question, where I seemed to have an unregistered library of some sort.

EDIT2: The DirectX End-User Runtime Web Installer freakishly worked and updated successfully. Now, I have focussed the question on the bigger problem. For WMP11, H&S, and Search, I click it once, get a busy icon for a second, and then nothing happens. Refer to EDIT1 for other problems.

EDIT3: Seems that my problems may be related to some Internet Explorer Script Errors. So what I did was download the IE8 installer from the Microsoft website, but when I run it and get to the main portion of the installer, it just keeps looping on the Downloading step of the installation. The installer is still running, but I left it for at least 4 hours and the downloading step was still not finished. What is the problem? Also, I uninstalled Ubuntu 9.10 after these problems, but they still remain.

EDIT4: I'm getting an active desktop recovery background on startup now. And within seconds my computer hangs again. EDIT3 explains main issue though.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I would try running "sfc /scannow" and downloading the Windows Installer 4.5. It may also help to do a system restore.

share|improve this answer
    
Managed to boot, but I cannot find the original disc. Will need to find some space to backup before System Restore. –  Wesley Feb 21 '10 at 2:00
    
Still same problem... I think my XP installation is corrupt or something. –  Wesley Feb 21 '10 at 3:46
    
Windows Installer 4.5 messes up all my .msi files, and they cannot open now. I will reformat. –  Wesley Feb 22 '10 at 5:39
    
Reformat complete, and my computer passed this scan successful. Thanks! –  Wesley Mar 4 '10 at 4:07
    
It is a shame you had to reformat. –  ta.speot.is Mar 4 '10 at 9:53
add comment

Not really a solution - more information on any error messages would be useful - but a couple of pointers that might help you diagnose the problem further.

One thing to check is that you have the "Show processes from all users" option on the Task Manager checked. That might be the cause of the missing processes, but as both Windows Media Player and the search are user instigated they should appear under your user name anyway.

I'd concentrate on fixing the Direct X issue first. If you can't get the 9.0c installer to work then you might need to take more drastic action, but without an error message it's going to be difficult (to say the least) to diagnose the problem.

I would have said that WMP is failing because it uses DirectX for drawing the visualisations, but you say it was working after the failed install.

share|improve this answer
    
Yeah, DirectX never seemed to install properly. But WMP still worked at the time. Weird thing now is that when I try to open User Accounts, I get a message saying "Wrong number of arguments or invalid property assignment." Seems that everything connected to Windows XP is just failing for some reason... I'll run virus scans, though I doubt that's the problem. –  Wesley Feb 17 '10 at 20:33
    
Panda Cloud not showing any virus or spyware. –  Wesley Feb 18 '10 at 0:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.