Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on FF 3.6 on OS X with Firebug 1.5 and whenever I am using Firebug, no matter what website I am on, a Javascript error always shows up:

setting a property that has only a getter Line 0

I have disabled all other add-ons but I still always get this error. It doesn't seem to affect anything but it is still annoying.

Any ideas on why this is happening?

share|improve this question
    
I have disabled all other add-ons -- including things like Greasemonkey, or proxies that might be adding JavaScript to all pages, right? –  Arjan Feb 17 '10 at 19:51
    
Yes, FB is the only add-on enabled. –  roflwaffle Feb 18 '10 at 0:16
    
Maybe this should go to stackoverflow.com? –  takeshin Apr 7 '11 at 15:12

4 Answers 4

It's more than likely a code problem on the websites that you visit. If the sites happen to be running say a google ad which is written in javascript and has a small bug, then your firebug will see this error and notifiy you about it. If that same ad is in many places the odds of running into that same error is great.

I personally would turn off Firebug when I'm not actualy working on a site/page.

Hope this helps some.

share|improve this answer
    
I get the error on personal sites as well, even when it's just static HTML. –  roflwaffle Feb 17 '10 at 19:17

I had the same error and it was because I was using a reserved word. This error only occurred on Firefox 3.6.3 for Windows and not in Firefox 8 on OS X.

Bad Code:

var history = new Array;

Changed to:

var historyx = new Array;

Now no longer throws error.

share|improve this answer

Confirmed to have the same issue with FF 3.6.3 and latest Firebug, BUT even if I deactivate or even uninsttall Firebug the issue occurs.

Check http://www.pixenate.com and see if you get the same issue there. Most likely you do, so this is a coding issue with some web apps (like Pixenate).

share|improve this answer

I've had the same annoying problem (though in my case it broke the app), and fixed it by using the try/catch statements. I couldn't find anything helpful online. Note, it fixed the app in both FF and Opera.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.