Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an NVidia ION board with 4 SATA ports and want to use that to run a Linux Server (CentOS 5.4). I first hooed up 3 HDs (that will be a RAID5 array) and a forth small boot HD.

I first started to use the onboard RAID capability but that does not work correctly under Linux: the raid capacity is not a real RAID but uses lvm to define some arays.

After setting the BIOS back to normal SATA mode and whiping the HDs, the first boot harddisk (/dev/sda) is seen as /dev/sda BEFORE mounting and after mounting as /dev/mapper/nvidia_. CentOS is unable to install on it (and grub is not installable on it either).

So somehow the harddisk is still seen as if it belongs to some lvm volume. I tried to clean out the HD by issuing a few dd if=/dev/zero of=/dev/sda commands to wipe the starting cylinders and final cylinders but to no avail.

Did anyone see this problem and did anyone find a solution?

UPDATE

When I create only a single ext3 partition on the first HD (/dev/mapper/nvidia_...) no LVM partitions are seen and I can boot from /dev/mapper/nvidia_.... Now the next step is to see how I can get rid of this folly.

share|improve this question
1  
ION's onboard RAID isn't real hardware RAID, it's fakeRAID. if you want to run Linux with RAID on it, you need to disable the onboard RAID in the BIOS and configure software RAID under Linux. –  quack quixote Feb 18 '10 at 14:55
    
@~quack: yes, I know! but somehow I cannot make the computer to understand I don't want it any more! –  Ritsaert Hornstra Feb 18 '10 at 17:15
    
which board are you using? have you tried clearing CMOS or setting BIOS to defaults? have you tried booting to LiveCD with no drives connected? have you tried examining the drives on another system? –  quack quixote Feb 19 '10 at 2:18
    
@~quack: I did clear the CMOS (with jumper on board: Point Of View MB330-1. Also resetting to default did not help, cleared out the HD. I did place it into an external HD container and the HD was found without any partitions but not directly on a SATA connectior though. –  Ritsaert Hornstra Feb 19 '10 at 7:12

1 Answer 1

up vote 3 down vote accepted

I think your problem has more to do with dmraid than LVM (see this note about a similar problem).

dmraid is the Linux fakeRAID facility. It and LVM (and MD RAID, Linux's software RAID facility) use /dev/mapper devices, but as far as I know, LVM requires a standard partition on the disk to use as a physical volume (PV). /dev/mapper/nvidia_* probably refers to a fakeRAID set on an NVidia chipset (using the sata_nv kernel module).

Under this theory, what's happening is that your kernel is detecting the presence of that old RAID metadata on the drives and auto-configuring the device mapper (via dmraid) to use them. If it was LVM, I think you'd be able to tell with fdisk -l /dev/sda.

If your goal is to get back to a plain-jane /dev/sda style disk access, you'll need to:

  1. Verify that DMraid or LVM are in use.

    • DMraid: try dmraid -s or dmraid -r
    • LVM: try pvscan or vgscan (?)
    • You should also try dmsetup ls to query the device mapper directly.

  2. If one or the other are in use, use those configuration tools to remove them.

    • DMraid: not sure. You can deactivate RAID sets with dmraid -an but this may not be enough. The manpage suggests dmraid -r -E can erase metadata, so that might be necessary.
    • LVM: pvremove or vgremove (or both)
    • You might also need to run dmsetup remove or dmsetup remove_all to delete devices from the device mapper driver.

  3. ??

In short, you may have to play with the dmraid, dmsetup and various LVM commands to see why your system insists on activating the device mapper. lsmod might be helpful to identify kernel modules in use so you can shut them down if necessary.

See also:

  • dmraid(8) and dmsetup(8) manpages
  • See this message for a look at RAID and LVM /dev/mapper devices. Not terribly relevant, but good context, and shows real-world use of dmraid commands.
share|improve this answer
2  
thank you thank you thank you thank you thank you. dmraid -r -E worked beautifully for me. dmraid -X isn't supported by the nvidia driver and this was driving me nuts. dmraid -an isn't enough btw, you do need to delete the metadata. –  DJ Capelis Mar 26 '10 at 9:25
    
@DJCap: glad it helped, thanks for the feedback! –  quack quixote Mar 26 '10 at 17:07
    
It did not help me but I am glad it helped someone else. Eventually I did get it to work after some tweaking (a bit more than I hoped) and I cannot backtrack what was the change that did it :(. So I will accept this answer since it did help DJ Capelis. –  Ritsaert Hornstra Mar 27 '10 at 11:17
    
@Ritsaert: it's a shame you couldn't post the fix here, but it happens. hopefully you learned from the process. –  quack quixote Mar 27 '10 at 11:21
    
Yes I know, I tried and I tried and got help from a veteran Linux nerd and at one point... it worked, and I cannot tell what did the trick. So yes, I am sorry because something was definitely mangled with the hds/mobo and I vow never ever to touch ION raid options again! –  Ritsaert Hornstra Mar 30 '10 at 20:52

protected by slhck Sep 15 '13 at 17:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.