Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know the workaround with @-key problems between linux and windows. I think I have a different problem.

I use Ubuntu 9.10 as virtualbox guest on a windows 7 host (synergy client). My Ubuntu 9.04 notebook is the synergy server. With the xmodmap lines the @ key is working well with windows 7. But in the virtualbox guest (Ubuntu 9.10) it won't work. How can I solve this issue?

The locale of both linux systems is de_DE.UTF-8

share|improve this question
    
(out of curiosity) what's the benefit to using a virtual machine as a synergy client? are you giving the guest its own monitor (eg, running it fullscreen on win7's secondary display)? –  quack quixote Feb 22 '10 at 11:26
    
That exactly what I am doing mostly. I have three monitors on one win7 host. I use virtualbox vm's mostly fullscreen on two of the three monitors. –  Marten Feb 24 '10 at 19:54
    
I know the workaround with @-key problems between linux and windows - I'm trying to find this workaround with no luck. If only you'd included a link :-( –  Dominic Sayers Jun 8 '12 at 11:02
    
add comment

1 Answer

up vote 0 down vote accepted

One workaround I found by myself. I use the virtualbox ubuntu machine also as synergyclient.

I did:

  1. Reconfigure .synergy.conf that my win7 desktop is up and the virtualbox ubuntu machine is left.
  2. disable 'mouse integration' with the virtualbox ubuntu machine
  3. run synergyc on the virtualbox ubuntu machine

Now I can go up to Win7 and left to Ubuntu system and all keys are working.

I hope there is another solution in the future

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.