Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I pinged my mailserver from the command prompt using:

telnet mail.mydomain.com 25

I got the error Telnet is not a recognized command. I looked for a workaround and then found that Telnet was unchecked by default in Windows. Once i checked it, it started working.

share|improve this question
2  
I don't know the exact answer, but I heard it was something to do with security. –  Sasha Chedygov Feb 19 '10 at 6:20
add comment

2 Answers 2

up vote 14 down vote accepted

TELNET communicates with the peer (telnet server) in clear text.
This is a security hazard compared to say the SSH connect. To this end, the telnet client on windows is disabled by default. This often comes as a surprise and many sites describe the steps to get it working,
you seem to have found them already :)

For normal purposes, it would be a better option to use SSH (PuTTY or freeSSHd if you want to connect to a Windows machine).

share|improve this answer
8  
My favorite part is that they disabled telnet and didn't give me ssh. D: –  Rob Oct 21 '11 at 15:31
add comment

When wanting to query in clear text an SMTP server, to my knowledge, there isn't any simpler way to do it than Telnet. [SSH can't be used for this]

In this case I advise you to enable telnet or to use something like SMTPDiag.

share|improve this answer
    
@simtris, I appreciate the ease of working with TELNET to talk with an SMTP server. I also agree that enabling TELNET is a good idea to connect with the SMTP server as the OP wants to. I see the question as a query on the reasons for something as simple as the telnet client needing to be enabled. Do you see a different question or think my answer deviates from the point in discussion? –  nik Feb 19 '10 at 11:53
    
@nik : U right, his question was about the "disapearance" of the telnet client. You anwer the part "security", I addead the part "usefull" :) –  user26604 Feb 21 '10 at 10:50
    
@simtris, fair enough :) –  nik Feb 21 '10 at 13:20
    
Since this question was referenced recently by answers to other questions, I have edited this answer to remove commentary on other answers (it's author lacked rep to make comments at the time). –  RedGrittyBrick Oct 21 '11 at 15:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.