Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer with two HDDs, one of which is dead. Booting the computer takes forever because the OS continues trying to access the HDD for a while.

Since I do not have physical access to the HDD, is there a way that I can disable the HDD in BIOS to prevent the OS from even trying to access it?

Alternatively, if there is a way to get the OS to quit trying to access it, that would help too. I am running Ubunu 9.04.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Without recompiling the kernel and basically a lot of trouble, I have no idea how to stop the OS from actually scanning for a hard drive as hardware detection/checking is one of the first things that happens.

I am guessing you have some sort of KVMoIP which is why you can access the BIOS but not physical access - I would personally ask the DC or whoever is in charge to disconnect it - however, if this is not possible, in the BIOS, where you see the hard drives, they are nearly always set to "Automatic" detection, if you set it to "Disabled", it should do what you want.

However, this is dependent on your BIOS and if it is not there, you may be out of luck.

share|improve this answer
    
Unfortunately, I was not able to find a way to disable the HDD in BIOS. It looks like I'm going to have to deal with it until I can physically remove the drive. Thanks for the informative answer. –  Aaron Feb 19 '10 at 20:31

In most BIOS setups, you can indeed disable a HDD in bios. The exact procedure depends on which BIOS/motherboard is involved.

share|improve this answer

Linux will go around the BIOS for some hardware even if it's been disabled.

Your best bet is to get someone who has physical access to unlock the case for you. Just removing the data cable should be enough (although powering a dead hard disk is kinda silly).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.