Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

YSlow always tells me my content is not served from a CDN no matter what value(s) I put in about:config extensions.yslow.cdnHostnames.

I've tried entering,, basically every variation I could think of and no matter what values I configure it never acknowledges it's hosted on a CDN.

Is this just a giant bug in YSlow or is there some kind of specified format that's not explained anywhere that it wants?

share|improve this question
I have the same problem! – James A. Rosen Mar 24 '10 at 6:02
up vote 2 down vote accepted

Try restarting firefox after you change the setting.

For me, I specified the domain name as "" - no http://. Then, when I ran yslow, it showed:

Using these CDN hostnames from your preferences:

but it was ignoring the setting. Restarting firefox and rerunning yslow seemed to do the trick.

share|improve this answer
This definitely explains alot as I would repeatedly change the values and not see any immediate results, I haven't verified this fully but I don't think I'm going to far out on a branch to accept this now. If it doesn't seem to matter I'll post again. – Chris Marisic Jan 12 '11 at 15:22

i've had the same problem, yslow required you to add the hostname only will not work, although will do fine.. at least for me :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.