Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 4 HDDs in my PC on a Gigabyte EP45-UD3 rev1.0 motherboard on SATA ports 0-3 and running AHCI mode.

Windows 7 refuses to let me install to any partitions or disks I select saying Setup was unable to create a new system partition or locate an existing system partition.

I will get to the bottom of this, after I sacrifice my Friday nights and weekends to Microsoft (they don't just want my money, they want my soul).

Keep tuned, if no one has the answer, I will find one. I suspect I have to rip out 3 HDDs so that the n00bs at Microsoft can actually deal with spinning media.

Really angers me how paid-for-products are so inferior to Linux they don't even qualify to be called "software".

share|improve this question
up vote 5 down vote accepted

Firstly, ensure that all other external disk drives are disconnected. This includes USB sticks, card readers, USB hard drives, the works. This worked for lots of people with the same problem here.

Download the SATA RAID drivers from Gigabyte's website and stick the drivers from GSATA\Floppy32 onto a floppy disk (see below) :-)

alt text

Bung it in your floppy drive and use F6 during Windows 7 when prompted to supply the correct SATA RAID drivers. This may allow the setup program to properly communicate with the disks.

Failing the above, switch from AHCI to ATA in the BIOS and try it again, if possible. If you need to know how to do this, refer to the manual here.

share|improve this answer
I removed my other 3 HDDs, and the installation worked just fine. – PP. Feb 20 '10 at 12:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.