Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Mail.app on Mac OS X 10.6.2 to send and receive mail to my gmail account. I also use my iPhone to send and receive mail on my gmail account.

When I send mail from Mail.app, it shows up fine in my Sent folder on Mail.app. When I send mail from my iPhone, it shows up fine in my Sent folder on my iPhone

However, mail sent from my phone does NOT show up in my Sent folder on my Mac, nor does mail sent from my Mac show up in my sent folder for my phone.

Here are my settings for both:

Mac Mail

  • Host: imap.gmail.com
  • Outgoing Host: smtp.gmail.com
  • Drafts: do NOT store on server
  • Sent: do NOT store sent messages on server
  • Junk: DO store on server
  • Trash: do NOT move deleted messages to the Trash mailbox
  • do NOT store deleted messages on the server

iPhone

  • IMAP account (not gmail)
  • Host: imap.gmail.com
  • Outgoing Host: smtp.gmail.com
  • IMAP Path Prefix: IMAP
  • Deleted Mailbox > On My iPhone > Trash
  • Deleted Messages > Remove > Never

In constructing these settings, I generally followed the recommendations on the google website. http://mail.google.com/support/bin/answer.py?hl=en&answer=77702 and http://mail.google.com/support/bin/answer.py?answer=78892

The obvious thing might be to check "DO store sent messages on the server" in Mail.app, but that goes specifically against the google recommendation, and if I recall correctly it also leads to copies of all sent emails showing up in the inbox on the iphone.

So what gives? How can I see my Sent mail on my other devices?

share|improve this question

3 Answers 3

"Sent: do NOT store sent messages on server"

Toggle this, and sent items will be stored on the Gmail server, thus enabling you access from both desktop and iPhone.

I would suggest you set all the "Store on server" options to Checked. Google's not always correct, or up to date; although they do try their best. I've never had issues with all the settings to store data on the server in the last 4-5 years Gmail IMAP has been available.

Also, look at what you have set as your Sent folder. In the list of mailboxes, scroll down until you see something like "Gmail" or whatever you named that account. Expand the list. If you see another folder in there with a name similar to "sent", it may be that your missing emails are there. Drag and Drop your known emails to this folder, then select it again, and from the menu, choose Mailbox > Use this mailbox for > Sent. Similarly for trash, junk, and drafts. I find it also helpful when dealing with an Exchange account over IMAP since Outlook on Windows XP has a different naming convention than Apple's mail client software.

share|improve this answer
    
Sure, but what about my concern regarding sent emails showing up in the inbox? –  emmby Feb 20 '10 at 5:22
    
Also, it's not obvious to me how that would fix the problem of iPhone sent emails not showing up on my Mac. –  emmby Feb 20 '10 at 5:31
    
@Mike: @Kio is right. Both your phone and your mac should store sent mail on the server, and that's how they'll stay in sync. Also, don't store them in your inbox, store them in "Sent" as Kio described. ("Use this mailbox for > Sent) –  Josh Feb 20 '10 at 22:40
    
Googling will turn up various links, but here's one link that explains why I think this solution will result in my sent mail showing up in my inbox: question-defense.com/2009/03/05/…. Not to mention that google recommends against that option. @Kio and @Josh, is there any particular reason why you believe this solution won't cause that problem? –  emmby Feb 22 '10 at 19:35
    
Even though that you do NOT check "store on server" GMail actually saves the sent mail in your sent folder online. So their recommendation is correct and error from Mail when sending are resolved. –  user149290 Jul 31 '12 at 6:04

I know this is a late response, but I've just noticed a similar problem. It seems to happen to all mail accounts/servers and not just gmail. It looks like the iPhone mail app and Mail.app are storing the sent messages in different folders. The iPhone is storing sent messages in a folder "Sent" (on the server) but Mail.app is storing the messages in the folder "Sent Messages" (also on the server)

share|improve this answer

I have set my IMAP Path Prefix to [Gmail] (with Brackets). Maybe this helps, I don't own an iPhone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.