Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several shares that are on my windows 7 system. The system I am accessing them from is an kubuntu 9.10 running gnome.

These are the lines I have in my /etc/fstab file

//192.168.1.136/Netstor /mnt/Netstor cifs username=Topsy,password=null,fmask=777,dmask=777 0 0
//192.168.1.136/htdocs /mnt/Htdocs cifs username=Topsy,password=null,fmask=777,dmask=777 0 0
//192.168.1.136/Downloads /mnt/Downloads cifs username=Topsy,password=null,fmask=777,dmask=777 0 0

I cannot create/change/delete anything in these mounted shares even though I have set the permissions to make them writable. How do I resolve this?

share|improve this question
    
is your user's password actually "null" or are you trying to send the empty string ("")? –  quack quixote Feb 20 '10 at 3:56
    
no, I just removed the actual pw. it is not null. –  Alex Feb 20 '10 at 4:48
    
What happens if you add ,noperm to the options? –  ephemient Feb 20 '10 at 8:04
add comment

2 Answers

up vote 1 down vote accepted

There is a helpful post on the ubuntu forums: http://ubuntuforums.org/showthread.php?t=1169149

With Vista/7 specific info.

This one: http://ubuntuforums.org/showthread.php?t=288534

Shows you how to correctly configure ubuntu, with I think a correction to your masks: 0777 instead of 777.

share|improve this answer
    
Adding 0777 instead of 777 did nothing. I will follow the guide in your link and report back with results. –  Alex Feb 20 '10 at 23:14
    
This guide worked. Thank you immensely. –  Alex Feb 21 '10 at 5:04
add comment

Try adding rw to the mount options. Also make sure you've supplied the correct permissions from the Windows 7 machine.

share|improve this answer
    
Could you provide an example of how that would look? Also the permissions are correct on the windows machine, I am able to do everything I need on the same machine when I boot into windows 7 instead (I dual boot), so that is not the issue. –  Alex Feb 20 '10 at 3:33
    
//192.168.1.136/Downloads /mnt/Downloads cifs username=Topsy,password=null,fmask=777,dmask=777,rw 0 0 –  John T Feb 20 '10 at 5:55
    
I tried your suggestion and I still cannot write/change/delete anything on those shares. –  Alex Feb 20 '10 at 7:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.