Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to run Windows XP on my computers. When I would use my MacBook, it would automatically show the computers in the left pane in Finder. Clicking on these would show me their network shares. I upgraded the computers to Windows 7 by reformatting, and now my MacBook won't do this. I can still connect to the computers using CMD + K but I kind of appreciated the ability for my Mac to auto-detect the computers.

I am wondering if anyone else is experiencing this. My computers are configured not to require a password to access the shares, and like I said everything works perfectly fine when I manually connect to them. A few months ago I searched for a solution, but the best I could come up with was something along the lines of adding the network shares to the start up list. I don't think this is a proper solution; what if I'm not at home where my computers with those shares are?

I imagined it had something to do with Bonjour, but both computers have iTunes installed which installs this Bonjour service. Bonjour is running, it's not what's creating this issue from what I can tell.

The workgroup name is MSHOME, and I have already tried explicitly defining the workgroup name (Though MSHOME is the default as far as I know), and this didn't do a thing.

I kind of gave up on it, but now that superuser is here I figured I'd ask here in case anyone might have any idea, or at least to confirm that this is happening with others.

EDIT: Can you guys please tell me if this is working for you? Or are you having the same problem? If I realize that many people seem to be having this problem, then I'll figure it is something that is out of our reach, maybe even a bug in Windows 7; I'm running the RC, or perhaps in Mac OS X. I'm running 10.5.7. Thanks I really appreciate it.

share|improve this question
    
Is there any update to this question? I am having the exact problem and was wondering if you solved the problem. Thanks. :) –  Ory Band Jan 10 '11 at 23:17

4 Answers 4

up vote 0 down vote accepted

I figured out how to make it auto detect your windows 7 computer on your macbook. Go to the airport network preferences. Then click advanced and after that the WINS tab select your workgroup and then put in the ip address of your windows computer. This should make it auto detect your windows 7 pc.

p.s. I'm running leopard

share|improve this answer
    
Entering an IP Address, is not automatic.?? –  Jonathan. Nov 12 '11 at 17:06

Make sure that your Windows 7 computers have the network type set to "Home" and make sure the File and Print sharing is enabled in the firewall. In Windows 7, sharing features are disabled by default.

share|improve this answer
    
Where do I set the network type? Also, remember that I mentioned that everything works fine if I manually type in the address to connect to it, smb://MyPC, it's the auto-detecting that fails. Just in case you missed that part. Thanks. –  Jorge Israel Peña Jul 22 '09 at 23:09

Did you create a Home Group on Windows 7? And let your MacBook join that?

If you Mac has trouble joining it, try this:

  • Goto Start Menu
  • Search for: seclpol
  • Hit Enter
  • Goto Local Policies> Security Options
  • Double Click on Network security: LAN Manager Authentication
  • Change level to: Send LM # LTLM Responses
  • Then Goto Network security: Minimum session security for NTLM SSP
  • De-select Require 128-bit encryption
  • Hit OK
share|improve this answer
    
Would my MacBook even be able to join a Home Group? I thought this was a new proprietary for Windows 7. If I can get confirmation that my MacBook would indeed be able to somehow make use of one though, then I'll try it. As for the security options: I had already done both of those things last time that I went searching for solutions. The only difference is that I had only removed the 128-bit encryption requirement from the NTLM SSP Clients, not Servers. I have now done it to the servers as well, I'll let you know if that does anything. Thanks though, I really appreciate the help. –  Jorge Israel Peña Jul 23 '09 at 18:34
    
Your welcome, problem is I don't have any OSX computer to test this one, but I reckon a MacBook is like a NAS or server to Windows 7. So it should be possible, but how? No idea :( –  Ivo Flipse Jul 23 '09 at 19:35

When I installed Windows 7 the default networking mode was not home, but something like public. This is actually a highly suspicious mode for using in cafés and street corners. No services will be advertised, and and I believe most types of sharing connections will be denied. The Home and Work (or is it Office) modes trust a little more than that and actually allow others to detect the machine on the network.

You set the mode by going to the "Control Panels" > "Network and Sharing Center". You should see the window divided in 4 parts the left margin, the top mini-map (Windows 7 -> Network -> The Internet), an active network below that, and below that, options.

If your network looks like a park bench, it is set as a public network. If you click on the "Public Network" linked text (frustratingly not the actual bench icon), you get a popup to pick a "Home Network" showing a house with a shield, or a "Work Network" showing two glass buildings with a shield.

CHI at it's best

Aren't they just adorable those little Microsoft CHI workers. Working so hard to make little concept art pieces and burying them in some unknowable location?

share|improve this answer
    
Thanks dlamblin, I really appreciate the help. However, my network was/is already set to Home network. When I click on advanced settings, I have network discovery on, file and printer sharing on, file sharing enabled for 40/56-bit encryption (not just 128), and password protected sharing off. –  Jorge Israel Peña Jul 23 '09 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.