Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

whenever I try co copy files in snow leopard to an external hard drive, i get in most of the cases "the operation can't be completed because you don't have permission to access"

I even tried to do this through BASH, but it just stops. Is it possible to get bash debug messages? Do oyu know the workaround to this?


share|improve this question

migrated from Feb 20 '10 at 10:23

This question came from our site for professional and enthusiast programmers.

maybe the files you're trying to copy are locked? cmd + i should give you an idea. – Tim Feb 20 '10 at 10:10
what is command+i for? (i changed a lot of time ago for quicksilver) – Werner Feb 20 '10 at 10:18
ok "get info", here i can see that i have read and write permissions for all users, but still the same problem – Werner Feb 20 '10 at 10:23
i've found this thread related with the problem: ,does anybody have problem with this extended attribites? – flow Feb 20 '10 at 17:39
up vote 0 down vote accepted

Is there enough room on the external hard drive? Are you trying to copy a very large file? Try creating a simple new test folder on both sides (hard drive and external drive), do you get the error?

Is this a restored os from time machine? (if so see

Is external hard drive over wireless or local, if wireless try doing it local.

share|improve this answer
could also be this problem also: – Joelio Feb 20 '10 at 13:02
I tried on two different disks, with 900G and 400G free space each it is not a large file, but a folder with a lot of subfolders. it should work anyway 3-about OS: it is a copy of and old windows xp machine – flow Feb 20 '10 at 14:52

Is the external drive formatted NTFS?

If so by default you don't have rights to write to the drive, only reading. You will need to install an applications like NTFS-3G for Mac which will allow you write access to an NTFS drive.

share|improve this answer
no, it is Mac OS Extended (Journaled) formatted – flow Feb 20 '10 at 14:51
Fair enough. I am however leaving my answer in case someone does have a problem with a NTFS drive. I have never had a problem with Mac formatted external drives on Snow Leopard. – BinaryMisfit Feb 20 '10 at 15:02
lucky you, lucky really – flow Feb 20 '10 at 17:24

Your running into cross platform issues... If I am reading this correctly.

Can you please verify that I am following the multiple threads here?

1 - The drive your trying to copy onto is a Mac OS Extended formatted disk? 2 - The disk you are trying to read is a NTFS or Fat32 Windows XP system disk

It sounds like your running into a filename incompt. issue. For example, on the Mac you can have a filename of "this is a great/\filename". But if you copy that to a PC, it'll freak out, and probably create a subdirectory (the ).

Same thing on the PC to Mac side, there a few characters that don't transfer well. It's less common on the Mac, because they have less restrictive filenames. But for example, don't use "::" as a filename...

My suggestion is to use the right tool... Download Winclone, and use that to clone the disk to a disk image... 1, it'll be compressed, 2, you can open the disk image, and retrieve any specific files you need, when you need them. 3, you can always clone the image, to a disk drive, if you want to boot from it...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .