Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 but it doesn't quite work right with Starcraft. (Colors are messed up).

So I installed Windows XP Mode and I can get it to play starcraft but it changes the resolution to 640x480 and it does not stretch - so it's running in a tiny window in the middle of my screen. (If I resize the VM then the screen either goes blank, or it doesn't resize the contents)

Also the mouse isn't captured - the mouse can go inside/outside the virtual pc easily, and it should get stuck on the edges.

share|improve this question
add comment

2 Answers

I'm going to answer your question about playing StarCraft on Windows 7.

You should run a front end like Chaoslauncher for StarCraft, instead of messing with emulation like XP mode. I use this on my copy of Windows 7 Home Premium, and it allows me to see the colors correctly. It also has the added benefits of letting me play in a window, with pixel doubling (e.g. 1280x960), and also it captures the mouse. (Press Alt to leave the window). It can also tell me my APM, disable annoying keyboard keys, and more. All in all, it's useful and open source to boot.

As for capturing the mouse in XP mode, I have no idea. :-p

share|improve this answer
add comment

XP mode by it's nature wants to run the application as if it was just another windowed application on the desktop that the mouse can easily go in and out of. You might have better luck if rather than running starcraft directly in XP mode, instead go launch the virtual machine that it resides in. Make the virtual machine full screen and then launch starcraft.

While in the virtual machine you could also try disabling the integration features under the tools menu. One of the integration features allows the mouse to go in and out of the window.

share|improve this answer
    
I went to the vmcx virtual machine file for xp mode and I opened it with Virtual PC. Still can't capture mouse even with control click and Integration Features Disabled. Fullscreen is still broken as well. –  Mike Blandford Feb 20 '10 at 19:57
    
just to be clear, when you're opening the vmcx, you see a start menu, desktop, and everything else for an XP machine? You might have to restart the virtual machine to get rid of the integration features. I don't understand what could be preventing the virtual machine itself from running full screen. –  Knox Feb 20 '10 at 22:10
    
oh - well it does go full screen, it just does not go fullscreen in 640x480 mode –  Mike Blandford Feb 27 '10 at 2:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.