Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At some point I configured X11 to be fullscreen on my Mac. Unfortunately, X11 on the Mac is hideous in fullscreen. There are drawing problems, where the menus aren't completely drawn for example, and the screen is constantly refreshing to redraw the entire screen. How can I get back to use the original version where X11 is integrated with the Mac OS apps?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Once in X11, try Cmd+Opt+A.

Then, go to the X11 Preferences via the menu, and in the 'Output' pane, uncheck 'Full-screen Mode'

X11 Preferences

share|improve this answer
    
This gets me to fullscreen mode. X still has a problem drawing the menus, for example. :-( –  anon Feb 20 '10 at 23:39
    
Hmm...I have a feeling X11-based programs are in general going to have poor Look&Feel compared to native Cocoa apps. However, I think I misunderstood your question; if you have 10.6 keep an eye out for 2.4.1 of XQuartz @ xquartz.macosforge.org/trac/wiki If you have anything older than Snow Leopard, try installing XQuartz –  Nextraztus Feb 20 '10 at 23:45
    
ok. I do have SnowLeopard. Didn't realize there was better X11 support with XQuartz. Will watch for 2.4.1. Thanks. –  anon Feb 21 '10 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.