Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 PC is set to automatically enter standby ("sleep mode") after 30 minutes. For some reason it stopped working a few days ago (it keeps on running). Is there some systematic way to determine what is preventing the system from automatically entering sleep mode after the designated idle time?

Manually sending the machine to sleep works fine. The monitor also enters power save mode automatically, so the "idling detection" of Windows seems to work fine.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Try running "powercfg -energy" from command line. Start it with admin privileges. It should tell you if there are some problems with your config.

share|improve this answer
    
Thanks, that gave me the information I needed. In case anyone is curious: Apparently, my on-board sound chip did not play well with the default Windows 7 sound driver: powercfg -energy listed "High Definition Audio Device" as "prevent[ing] the system from automatically entering sleep". Replacing the generic driver with the sound chip driver from the motherboard manufacturer solved the issue (and added yet another useless icon to my systray... oh, well, at least Windows 7 hides them by default). –  Heinzi Dec 6 '10 at 0:19
    
That icon might (or might not) as well be vanquished. Its app must have been installed together with the driver you got from the motherboard manufacturer. Many times these apps are some advanced volume/balance/whatever controllers. Most of their features are available from the Windows Sound Mixer or Speaker properties so if you don't need them you should exclude it from the startup. It's worth a try. The drivers will load anyway. At least, they should. –  gemisigo Dec 7 '10 at 15:18
add comment

after running powercfg -energy I assume there is a Error for \FileSystem\srvnet. This is the media sharing server i believe.

Turn off media sharing. easiest way is to go to HomeGroup settings and Leave the Homegroup. this will turn off Media sharing. This should sort it out.

now if you run powercfg -energy again that error should disappear.

Let us know if this solves the issue. thanks

share|improve this answer
    
As it turned out, media sharing was not the culprit in this case, see my comment on user30539's answer. Thanks anyway for your help! –  Heinzi Dec 6 '10 at 0:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.