Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had a look through all the related questions and I get the feeling my problem is unique.

My wireless connection disconnects every 30 minutes, for maybe 1 to 3 seconds. If I am browsing the web while it happens, I get the page cannot be displayed error message.

I have checked the event logs as I was curious to know if there was anything in there.

There is.

Event 8033: BROWSER - The browser has forced an election on network
\Device\NetBT_Tcpip_{B919CC30-25A9-45DD-A09F-549A6262FC9E} because
a master browser was stopped.

Reported exactly every 30 minutes which coincides with my wireless problem.

I am running Windows 7 Ultimate, 32-bit. My wireless is Realtek RTL8187 integrated into a ASUS P5K-E/Wifi motherboard. It is on a workgroup and has never been on a domain.

This problem does not affect any other computers.

Wireless reception is great, and I have ensured that the wireless unit is transmitting on a frequency not used by any nearby wireless basestations.

How can I fix this pesky problem?

share|improve this question
That's likely a consequence of the lost network connectivity. The error msg is related to SMB (the file sharing protocol), not web browsing. – Tony Lee Feb 21 '10 at 15:28

5 Answers 5

up vote 8 down vote accepted

I think I know what this might be, as I have been egtting the exact same thing on my new Netbook and it has been driving me crazy. Every 30 minutes, regular as clockwork.

Are you using WPA-PSK ? I am. On my Zyxel router there is a setting "ReAuthentication Timer (In Seconds) " and this defaults to 1800 ( 30 minutes ). Sure enough, if I change this to 60 seconds, the problem now occurs every minute. Set it to 120 and it occurs every 2 minutes.

Check your router to see if you have this setting.


share|improve this answer
You've hit the nail right on the head with that answer... I have a ZyXEL too and I'm using WPA-PSK. I tried what you suggested and bingo, reconnects every minute. I guess to anyone else having a similar problem, check under the wireless settings section of your router for any kind of time setting that matches whatever period of time you find yourself being disconnected after. As I have no way of completely disabling that setting (without turning off WPA-PSK), I guess a shiny new router is on the cards for me :-) Thanks again. – Kez Jul 14 '10 at 22:59

Have you updated to the latest drivers for the wireless card and BIOS for the motherboard? If it is a repeatable pattern that happens like clockwork, I'd venture a guess that one of these two updates will fix it.

share|improve this answer
Thanks, all updated to the latest versions, still having the same problem :S – Kez May 13 '10 at 9:05

Start regedit and navigate to:


Change the MaintainServerList key to No, save the key, close regedit and reboot.

share|improve this answer
No go with this unfortunately. – Kez May 13 '10 at 9:07

Any chance that some electric device (not necessarily a wireless or anything having to do with radio "by design") is kicking in every 30 minutes in the vicinity?

Things like fridges, anti-theft/intrusion sensors, traffic lights, water pumps? Electric motors (especially very old models who were set in place well before the advent of wifi) could maybe create interferences, and these could be magnified whenever the motor ramps up (i.e. starts).

In any case, have you used sniffers/monitors like ethereal to verify what happens at the wifi level?

share|improve this answer
Will have a look with ethereal, thanks for that. I have a laptop running Windows 7 too, absolutely no problems with it - which at least helps rule out the router as the cause. Although, saying that I guess it could still be interference if the wireless receiver in the desktop computer is more sensitive than the one in the laptop.... – Kez May 13 '10 at 9:06

Some hotel and airport networks do this same periodic cutoff. I found the "Wifi Web Login" Android app useful in this situation. It reconnects your device to the network. Use PdaNet to connect your handset to your laptop via USB data cable. This works fine for me during a 2 hour layover at the airport, and keeps my phone charged as a side benefit.

One additional benefit: in case they disallow a reconnect with the same MAC address, you may be able to alternate between handset and laptop which changes the MAC address.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.