Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

hey guys, I have a gigabyte ga-k8nmf-9 mobo which has both sata 1 and sata 2 support. Until a few hours ago I had a samsung 160gb sata 1 hdd which worked ok until it failed. I bought a wd se16 caviar, 500 gb, 7200 rpm, 16 mb cache, but it seems that it's not properly detected by my computer - it's only showing 137 GB out of 500. I tried a BIOS update (to F10e) and it's still doing the same thing. I've altered BIOS settings to use only sata (no ide) and many other settings, but nothing worked.

Any help will be greatly appreciated

Update on this one: it seems that the previous hdd was doing the same thing, though I didn't notice because it was approximately the same size

share|improve this question
add comment

2 Answers

Looking at the spec for that motherboard, it certainly seems new enough to support that size of drive.

Firstly, are there any jumpers on the drive? If so then there may be one that sets it to limit its apparent size for operating systems that do not support LBA48 (i.e. Windows XP before SP1). Check the lables on the top of the drive, or try find the drive's tech specs on the manufacturer's site, and make sure they are in the right place on your drive in order for it to not have the restriction. See http://www.pcguide.com/byop/byop_SettingHardDriveJumpers.htm (the first decent result for "drive jumpers" in Google - you may find a better resource if needed) for relevant pictures.

Secondly, where is the 137Gb being reported to you? Is it being reported by your OS or by the BIOS setup screens. If it is the OS then this may be the issue - older OSs will not support LBA48 which is needed to address above that size limit. IIRC Windows XP did not originally support LBA48, support was added in either SP1 or SP2. Another possible cause is drivers - ensure that you have the most uptodate drivers for your I/O controller (i.e. your motherboard drivers or if you are using an add-in I/O card the drivers for that card).

share|improve this answer
    
Thanks for your answer David. That size is reported both by bios and OSs (windows and linux). The drive has no jumpers, but I tried to enable 150 MB/s operation with a jumper - nothing yet :( –  hyperboreean Feb 21 '10 at 16:48
    
Jumpers for SATA/SATAII (150/300) should not affect the apparent size of the drive. Your old drive doing the same thing, and both the BIOS and OS seeing the drive as too small, implies the problem is in the BIOS and not the drive (especially as the drives are different manufacturers). It seems odd to me that this board doesn't support larger drives but you'll need to check the manufacturer's specs to be sure. If it simply doesn't support them them at all you'll need to get an add-on I/O card to use the rest of the drives. –  David Spillett Feb 22 '10 at 13:16
    
David: the board does support it ... but I might miss something, I have no idea what ... I have tried every possible option that I could come up with. –  hyperboreean Feb 22 '10 at 20:35
add comment
up vote 0 down vote accepted

Both HDDs had the firmware pretty much broken ... I've changed them and now everything runs smoothly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.