Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My setup is a laptop with Windows 7 64-bit, Visual Studio 2008 SP1 on an Intel X25-M 4 GB SSD with page file turned off (no need) and 2.2 GHz Core Duo.

What happens is weird: When I build my project and attach the debugger the symbols load REALLY slowly... like 1 every 5 seconds.

Sometimes the symbols will fail to load at all. This is driving me crazy as this was a freshly installed Windows 7 box with default Visual Studio installation, working on ASP.NET web applications...

I've never had to use symbol servers or any of that jazz so I'm quite frustrated. With this SSD it should breath fire as it does with loading and doing everything else.

Am I missing something?

share|improve this question

migrated from stackoverflow.com Feb 21 '10 at 16:11

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Turn ON page file & see if that helps!

share|improve this answer
    
There is almost never a good reason to disable your pagefile. See blogs.technet.com/markrussinovich/archive/2008/11/17/… and lifehacker.com/5426041/… –  Stephen Jennings Mar 21 '10 at 23:32

Except for the fact that with a MLC based SSD write magnification from constant writing to disk is actually a slow operation. Add 4gb of RAM (so nothing ever gets paged) and you run out of a need to have a page file.

the machine runs awesomely doing everything BUT debugging. FYI this ended up being an issue with debugging with the T-SQL turned on. by unchecking this as an option it all came good.

But thanks for the shutdown without any research.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.