Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
ubuntu@ubuntu:/usr/lib/locale$ sudo rm -R nl_NL.utf8
rm: cannot remove directory `nl_NL.utf8': Input/output error

I'm having problems deleting a seemingly corrupted directory to allow for a reconfiguration of this locale, but the OS doesn't let me do it. Why?

share|improve this question
add comment

4 Answers

up vote 10 down vote accepted

I suspect filesystem corruption here. As this is likely to be your root filesystem you won't be able to do a full fsck while the system is live, so do sudo shutdown -r -F now which should shutdown and reboot (the -r) forcing a run of fsck (the -F) as the system comes back up (at a point where issues found can be more safely fixed). You might want to update your backups first, if only for the sake of paranoia (in case something is seriously wrong and the machine won't reboot cleanly).

It could also be a file locking issue, though I would expect a different error message in that case. To see what processes are actively usng those files you can run lsof | grep locale.

share|improve this answer
add comment

Four hours later I found the solution to my problem:

  1. I rebooted the PC and in the boot menu I started an instance of the Ubuntu Recovery menu-item.
  2. I opened a terminal session as root and was able to delete the direcory with the command:

    rmdir ".gvfs"
    

    No error message came back.

  3. I checked the removal with another ls -al command. The directory file was no longer in the listing.
  4. I rebooted the PC and saw that the result was perfect. The unwanted, uncontrollable file on the desktop was not there anymore. Problem solved.
share|improve this answer
add comment

I had a similar problem and while I performed the FSCK I was prompted :

Entry 'file.dat' in /Folder (7782401) has deleted/unused inode 9519105. Clear? yes

This solved my problem.

share|improve this answer
add comment

Another solution for those who might be encountering this issue on a disk that is formatted as NTFS is to boot into Windows and remove the folder from there. Alternatively, one could boot into Windows and run a CHKDSK command on the NTFS formatted drive which is throwing the error.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.