Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes when I download a PDF, Chrome will open a new blank tab, how do I prevent this?

share|improve this question

2 Answers 2

The only way to stop the blank page is to use Right Click and Save Link As.

Since Chrome does not natively support an embedded PDF reader it assumes the PDF link is trying to open another page. It then let's the file system take over allowing your PDF reader to open the actual file. It doesn't have any facility to close the new tab that opened as it assumes it is being used for displaying the file.

However there is good news. You can use the Docs Preview Extension to preview all these documents in Chrome and it will stop this behaviour since the files will open in Chrome.

Newer versions of Chrome does support embedded PDF viewing so a lot of this answer is obsolete

share|improve this answer
    
I don't want the file to open in chrome. That is the polar opposite of what I am asking. The issue is that, a blank page opens on downloading a PDF. I want the file to be downloaded, minus the blank tab I have to close. –  finiteloop Feb 21 '10 at 18:47
    
@segvault. Updated my answer with a more detailed explanation. The short version however is you can't because of the way chrome handles the link. It doesn't know what it's opening. –  Diago Feb 21 '10 at 18:52
    
@Diago so do you know of an extension that may be able to figure this out? Or some feature request submitted to Chrome for this functionality? –  finiteloop Feb 21 '10 at 18:56
1  
@segvault. No to both. I doubt it is considered a bug as the browser is doing what it's meant to. I have experienced the same using IE and Firefox in the past unless I have a PDF reader installed. I can remember it being a problem when we were developing a website that produced PDF's. We ended up sending the PDF as a binary stream and not a link which forces the browser to open the PDF Viewer or prompt the user to download. –  Diago Feb 21 '10 at 19:01
    
I mean, I know its not a bug. But I can't think of a case where such activity is desirable. Who would prefer there being a blank page to not being a blank page? I am able to avoid that from occurring in Firefox by changing a preference in the Download Statusbar add-on. –  finiteloop Feb 21 '10 at 19:14

Okay, I got it to do this finally.

  1. Go to about:plugins and disable the Adobe Acrobat Adobe PDF Plug-In For Firefox and Netscape

  2. Open Adobe Acrobat and go to edit --> preferences --> internet and uncheck "display PDF in browser"

(Steps 1 and 2 might be redundant, but this is what I did and it worked.)

  1. Click on a PDF link. Depending on your settings, you will either get a popup asking where to save the PDF, or the PDF will save automatically to your specified directory. If you want all PDFs to auto-open, click the little arrow to the right of a PDF download, and select "Always open this type of file".

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.