Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop and a laptop (both running windows 7) in my Windows 7 homegroup. The desktop created the homegroup, and the laptop joined it. Both share a few folders.

On the laptop, I have no problem accessing the Desktop's shared folders via the "Homegroup" sidebar button in Windows Explorer.

However, on the Desktop, I get the message No other homegroup computers are currently available in the homegroup screen. However, if I go to the Network page, I can see the other computer and browse its shared media. These shares were made by right clicking and choosing "Share with Homegroup".

I can access the media, so this isn't a big problem, but I'm just confused as to why the Homegroup screen denies the existence of the other computer. Has anybody else encountered and resolved this?

It occurs to me that the homegroup stuff uses IPv6, I think, and so perhaps some networking gear isn't working correctly in between. I don't have this setup anymore, so I can't verify that hunch.

share|improve this question
    
Are the other computers running Windows7? If so, have they "Joined your homegroup" as it were? Are they actually "Sharing anything with the homegroup"? –  Grizly Feb 21 '10 at 21:41
1  
They're both running 7; They've both joined the homegroup, they're both sharing things with the homegroup. –  McPherrinM Feb 22 '10 at 1:11

5 Answers 5

I'm not terribly sure here. Are the computers on the same workgroup? (Control Panel -> System, shows the name and workgroup) I had this issue a lot with the Beta, but I assumed that by the RTM they had worked out the bugs in it.

Believe it or not, the solution that worked for me was simply to recreate the homegroup using a different password. That seems to reset everything about it, causing windows to like you more.

Things to check: Make sure both computers think it's a "Home" network. (Network and Sharing center lets you change the network type.) The homegroup feature needs IPv6 support from your router to work, but they can obviously see each other, so that's not it. Make sure that your laptop is set up with the proper permissions-- you can set advanced Homegroup settings and I think you can turn filesharing and discovery off for "Public" networks; make sure it's on for home networks.

If you use the same login for both computers, it's likely that one of them simply has homegroup sharing turned off. The network computers option doesn't rely on homegroup settings at all, and if the login creds were different, would prompt you for a username/pass when trying to access files on the other machine. Homegroup itself is a convenience layer so that you don't need to do that for computers you trust.

share|improve this answer

For me, the PC that created the homegroup didn't show up after it had been re-installed, but all others were.

I just removed from Homegroup then re-added. Thats all it took for me.

I don't Think it matters which machine creates the home group, as long as when you're re-adding, or adding a new one, that one of the PC's in that homegroup is active and visible.

share|improve this answer

I've had problems with 1 Desktop with manually assigned IP address, the other desktop on DHCP from the router. If you manually assign a DNS server when manually assigning the Ip address, different from the actual router DNS assignation, the other PC's can see the main desktop through Network icon, but not through Homegroup. All PC's in the Homegroup MUST be on DHCP from the router. Restart all PC's and set the homegroup up from scratch after ensuring all PC's are on DHCP - NOT manually assigned addresses.

share|improve this answer
1  
Do you know where documentation of this can be found? I have one PC with a manually assigned IP address, and another with a DHCP address. The DHCP-addressed PC can access the Homegroup-shared resources of the manually-addressed PC if "logged in". It'd be a nuisance to switch to DHCP addressing for the manually-addressed PC. –  bgvaughan Sep 27 '11 at 16:21

Try removing the homegroup, restarting the PC and recreating the homegroup with same name and other settings.

Don't choose "I am connected directly and others are in my network"; choose "all in same network." No one should be host or client.

After doing that, enable remote access, so you can have access to other PCs for their files and for full control.

share|improve this answer

This article may be able to help if you have "Microsoft Security Essentials" installed:

http://www.7tutorials.com/fix-problem-homegroup-computers-not-being-available

Essentially, it tells you to uncheck the "Enable Network Inspection System" in that program's settings under "Real-time protection".

Otherwise (like in my case), it is most likely your firewall and homegroup not playing nice with each other (which is probably a good thing if you think about it...). Try temporarily disabling firewalls on both machines to confirm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.