Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have FireFox as my desktop's default browser (Ubuntu/Gnome 9.10) and most applications open links into FF readily enough, including Choqok (a KDE twitter client).

But Kopete insists on opening Konqueror - which is annoying as it takes an age to load, while FF is almost always open an simply needs a new tab.

I've checked though the preferences of Kopete, and can't seem to find anything to make it use FF.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You can use KDE's "System Settings" tool by launching systemsettings or find it on your menu. Then under Default Applications you'll find a Web Browser option.

OR

Edit ~/.kde/share/config/kdeglobals and alter the line with BrowserApplication[$e] to read:

BrowserApplication[$e]=!firefox

That should do it, and this assumes you are using KDE4.

share|improve this answer
    
hi - i'm running Kopete on Gnome... –  HorusKol Feb 23 '10 at 23:40
1  
Right, but Kopete will still need a base KDE install to run so that file should exist for you, even if you don't have systemsettings. Your config dir might be ~/.kde4 also. –  SleighBoy Feb 24 '10 at 20:17
    
this is going to sound strange - but i think i did it... and i think i did it following your instructions. but that was a couple of weeks ago, and now i can't find how i did it or where it is set... –  HorusKol Mar 25 '10 at 6:29

A kind of SleighBoy's solution works for me under 10.04 LTS. I had the same problem (wanted to open chrome instead FF). I added lines

[General]
BrowserApplication=google-chrome

at the end of kdeglobals and it worked

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.